Best Blu-ray Deals

Best Blu-ray Deals, See All the Deals »
Top deals | Price drops  
 All countries United States United Kingdom Canada Germany France Spain Italy Japan
The King and I (Blu-ray)
$10.00
3 hrs ago
Thor: The Dark World 3D (Blu-ray)
$19.99
10 hrs ago
The Dick Van Dyke Show: The Complete Series (Blu-ray)
$49.99
 
Fargo: The Complete First Season (Blu-ray)
$19.99
21 hrs ago
Ice Age 4 Movie Set (Blu-ray)
$16.99
8 hrs ago
Dawn of the Planet of the Apes (Blu-ray)
$11.99
 
Arrow: The Complete Second Season (Blu-ray)
$19.99
 
Zodiac (Blu-ray)
$4.99
11 hrs ago
Planet of the Apes: Legacy Collection (Blu-ray)
$17.99
18 hrs ago
Sleeping Beauty (Blu-ray)
$18.99
 
Harry Potter: Complete 8-Film Collection (Blu-ray)
$44.99
 
The Complete Jacques Tati (Blu-ray)
$59.99
 
The Big Bang Theory: The Complete Seventh Season (Blu-ray)
$19.99
 
COLLECT WATCH TRACK RATE REVIEW APP
Manage your own movie collection and always keep it with you with our Apps. Price track movies and get price drop notifications instantly. Become a member to take full advantage of all site features.
GET STARTED

Go Back   Blu-ray Forum > Blu-ray > Blu-ray Players and Recorders

Reply
 
Thread Tools Display Modes
Old 06-30-2011, 07:41 PM   #41
DK80 DK80 is offline
New Member
 
Jun 2011
Default SONY BPD 350 peculariaties

I have had a model 350 for about 2 years and so far it seems to be able to play anything I put in except for CD-ROM 'data' disks (that can be played on a Toshiba DVD player) and Blu-Ray disks created on a LaCie burner. These disks can be played using the LaCie as a drive, so this must either be a cleaning problem or a peculiarity of the SONY. I will experiment and report back.

Fortunately (or unfortunately as the case may be), I have not upgraded anything.
  Reply With Quote
Old 07-11-2011, 04:31 AM   #42
headroom headroom is offline
New Member
 
Jul 2011
Default blu ray disk plays only the first time

Anybody have this problem? Blu Ray disk plays perfectly the first time, but when you try to play it again (whether you have taken it out, powered off the machine or not) it won't get past the main menu. When you hit "play movie" it freezes and won't come out of the player- the player must be powered off by depressing the power button for about ten seconds. Then you can eject the disk but it still won't play no matter how many times you try. I have the latest BDP-S350 firmware upgrade. This happened on two Blu Rays recently from Netflix. I called them and the guy I spoke to had not heard this one before. But he said in the last several months there's been a big increase in people asking for replacement disks, and when they get them, they don't play either.
He attributes this to new disk programming by the studios. The tipoff is, if the previews play (which they do in my case) but then the movie itself won't play. He says the movie is programmed with different code than the previews.
He also said there would be no point to buying a new Sony player, as you would no doubt be using the same firmware you already have. In his opinion, there's nothing that can be done about it until the manufacturers figure out how to over come this with another firmware upgrade.
I'm hoping somebody can shed more light on this situation. Since I find that most disks play fine, and even the previews as mentioned above, I don't think I have a laser lens cleaning issue.
  Reply With Quote
Old 09-01-2011, 02:05 AM   #43
Shaun Weiss Shaun Weiss is offline
New Member
 
Sep 2011
Default Major issues also

I had a sony bdps500, not only would it not play probably one third of the blu rays I put in it, I got a 'Cannot Play" message with quite a few regular DVD's, also, it wouldnt play practically any regular dvd's that were more than eight years old. I thought, being it my first blu ray player, that the whole blu ray format was like this and it was something I had to live with. Then, about six months ago, I got a cheap 100 dollar Toshiba player for the basement TV, and the thing just flew, breezed quickly and easily through everything I put in it, while I had to constantly unplug the Sony from the AC line while powered up, because the player would become completely unresponsive, and plug it back in again just to get it to eject a disc. I then literally unplugged from my system the Sony and threw it in a fit of frustration into the dumpster. I replaced it with a Pioneer Elite, no issues whatsoever. This tells me that this just has to be that the Sony line of players are poorly engineered. The Pioneer and Toshiba just rip. ...
  Reply With Quote
Old 09-10-2011, 03:27 PM   #44
kepople kepople is offline
New Member
 
Sep 2011
Default

So is there a solution or is this just a bug?

Is it possible to have a dirty lens?

Thanks
Kirby
  Reply With Quote
Old 09-13-2011, 06:46 AM   #45
blu-bren blu-bren is offline
Senior Member
 
blu-bren's Avatar
 
Jul 2009
Australia
39
441
282
6
Send a message via Yahoo to blu-bren Send a message via Skype™ to blu-bren
Default

i have this machine too but when i have the hdmi plugged in the player or cord mess up by flickering on and off but this really happens only with dvds inserted.

so i plugged in compiknant video cords instead.
i just watch in 1080i now.
i've rented movies BDs that just would take ages to load or not load at all.
Fox ones
(date night and percy jackson)
set up:
Panasonic superdrive vcr; Sony 3D bluray home theater system BDVE2100; Laser Blu-1080 Bluray Player
  Reply With Quote
Old 09-13-2011, 06:50 AM   #46
blu-bren blu-bren is offline
Senior Member
 
blu-bren's Avatar
 
Jul 2009
Australia
39
441
282
6
Send a message via Yahoo to blu-bren Send a message via Skype™ to blu-bren
Thumbs down

i have this machine too but when i have the hdmi plugged in the player or cord mess up by flickering on and off but this really happens only with dvds inserted.

so i plugged in compiknant video cords instead.
i just watch in 1080i now.
i've rented movies BDs that just would take ages to load or not load at all.
Fox ones
(date night and percy jackson)

plus 2 others

sin city : the game with the remote control and terminator salvation in movie mode


SUCKS!
set up:
Panasonic superdrive vcr; Sony 3D bluray home theater system BDVE2100; Laser Blu-1080 Bluray Player
  Reply With Quote
Old 09-14-2011, 05:45 AM   #47
blu-bren blu-bren is offline
Senior Member
 
blu-bren's Avatar
 
Jul 2009
Australia
39
441
282
6
Send a message via Yahoo to blu-bren Send a message via Skype™ to blu-bren
Default

anyone new updates? firmware.
set up:
Panasonic superdrive vcr; Sony 3D bluray home theater system BDVE2100; Laser Blu-1080 Bluray Player
  Reply With Quote
Old 09-22-2011, 02:57 AM   #48
zeonstar zeonstar is offline
Member
 
Nov 2007
6
8
Default

I have the Costco version of the player and I've came across my first disc that just wont play: X-Men First Class. Anyone else having trouble with it?
  Reply With Quote
Old 10-06-2011, 03:54 AM   #49
Rhylliam Rhylliam is offline
Contributor
 
Rhylliam's Avatar
 
Oct 2008
Calgary, Alberta
16
1533
820
44
82
Default

Had my player for 3 years now & just started having this issue... 1st disc was Alliance's The Mechanic, & now disc 2 of Louie Season 1 will not play.

Am I to believe that there is still no solution or idea why this is happening?
2051 DVDs,
1296 Blu-rays,
166 HD DVDs,
38 Laserdiscs
& counting...

Sale/Trade Thread (new titles regularly: Canadian exclusives, slipcovers, steelbooks): http://forum.blu-ray.com/showthread.php?t=116007
  Reply With Quote
Old 10-08-2011, 10:41 AM   #50
gadsilla gadsilla is offline
Member
 
gadsilla's Avatar
 
Nov 2008
The Netherlands
7
844
273
Default

Fortunately (or unfortunately as the case may be), I have not upgraded anything.[/QUOTE]

Same here and after more than 2 years it still works fine..(knock on wood)
  Reply With Quote
Old 03-10-2012, 04:43 PM   #51
Inswimmer Inswimmer is offline
New Member
 
Mar 2012
Default

Quote:
Originally Posted by Rhylliam View Post
Had my player for 3 years now & just started having this issue... 1st disc was Alliance's The Mechanic, & now disc 2 of Louie Season 1 will not play.

Am I to believe that there is still no solution or idea why this is happening?
After playing a new bluray disk (Warrior in my case) I could not play any subsequent bluray disks on my Sony BDP-350; I get an "UNKNOWN" error on the player and the TV screen has a "Cannot operate this disk" error message. Upon further investigation, I find this only true for newer disks (Expendables, Star Trek) and not older disks (pre-2009)

I found this gem in the avforum.com:
"I've had the "unknown disc" thing lately with some titles, and what's worked for me is to first play an older, known working title until it gets to the FBI notice, then eject and put in the newer disc."

This has worked on a hit or miss basis for me. I have the latest Software Version 07.4.024 and no firmware updates are available. I think I'm going to get a new player today, the BDP-350 came free with my TV purchase. Hope this has helped someone out. Cheers.
  Reply With Quote
Old 03-10-2012, 04:47 PM   #52
Cortiz Cortiz is offline
Power Member
 
Cortiz's Avatar
 
Jun 2007
Sunshine State
211
Default

Quote:
Originally Posted by Inswimmer View Post
After playing a new bluray disk (Warrior in my case) I could not play any subsequent bluray disks on my Sony BDP-350; I get an "UNKNOWN" error on the player and the TV screen has a "Cannot operate this disk" error message. Upon further investigation, I find this only true for newer disks (Expendables, Star Trek) and not older disks (pre-2009)

I found this gem in the avforum.com:
"I've had the "unknown disc" thing lately with some titles, and what's worked for me is to first play an older, known working title until it gets to the FBI notice, then eject and put in the newer disc."

This has worked on a hit or miss basis for me. I have the latest Software Version 07.4.024 and no firmware updates are available. I think I'm going to get a new player today, the BDP-350 came free with my TV purchase. Hope this has helped someone out. Cheers.

I would recommend buying one of those BD Lens Cleaner and try cleaning the player first. That has worked for on svereal occassions, in fact now I do it every month or so to keep that sensitive lens clean.
  Reply With Quote
Old 07-18-2012, 10:45 PM   #53
darkest hour darkest hour is offline
Junior Member
 
May 2010
Default sync problems?

Has anyone noticed their Sony s350 starting to have problems with sync issues?, lately it seems every movie i watch now has problems with sound sync.It only seems to be of a few milliseconds but its very annoying.Anyone else starting to have this problem?.
  Reply With Quote
Old 07-22-2012, 04:03 PM   #54
Veronica Mars Veronica Mars is online now
Blu-ray Guru
 
Veronica Mars's Avatar
 
Dec 2009
Scottsdale, AZ
691
121
192
Default

After a very recent firmware update, this gives me the unknown disc message on just about everything that I put in it. Date the Blu was released seems to have nothing to do with it. I put in Phenomenon and Frequency and both were unknown and then after trying more discs with no luck I got Phenomenon to play. Then I tested to see if it would play again and it wouldn't. Ugh. This doesn't seem like a lens issue. Thing worked perfectly until I did the firmware update. Now the player is basically junk.

So are a lot of people having this problem? Any chance Sony can "fix" this with another update?
  Reply With Quote
Old 07-25-2012, 04:41 AM   #55
joblack3001 joblack3001 is offline
Member
 
joblack3001's Avatar
 
Mar 2011
USA
506
134
1
Default Brooklyns Finest

Crazy mine did the same thing with only that movie, wierd part is I just got it to play.. Idk
  Reply With Quote
Old 12-29-2012, 03:01 AM   #56
agarr14 agarr14 is offline
New Member
 
Dec 2008
589
134
Default

Has anyone been able to solve the "Unknown Disc Error" that has been happening with the Sony BDP-S350? Mine has been doing it quite frequently for the past two months. What I have discovered is it really only does it when I want to watch a second Blu-ray. I have taken apart the drive and cleaned the lens so I know it's not the lens being dirty, also for the fact that dvd's and cds play just fine. My friend thinks it has to due with the fact that the laser lens is not resetting itself once you stop the movie and insert the second disc, which he believes is a firmware issue once I told him it started happening not long after I noticed it had upgraded. Once I can get the player to recognize the movie it plays perfectly, but it is frustrating to keep getting the "Unknown Disc Error"

Thanks,
Adam
  Reply With Quote
Old 01-05-2013, 11:36 PM   #57
drevill drevill is offline
Junior Member
 
May 2010
Canada
543
38
Default

We just tried watching Sound of Music on a BD-350 today, and it would not load. We were able to watch it via my laptop (and HDMI hookup) though, so at least I can confirm the disc isn't defective.
Afterwards I tried leaving the disc in the Sony machine again, and after 12 mins it would not load. No error messages popped up though.
The firmware is up to date, and I have tried other discs, and no issues (yet). Anyone else have this problem with Sound of Music?
  Reply With Quote
Old 01-05-2013, 11:42 PM   #58
rdodolak rdodolak is online now
Blu-ray Ninja
 
Jul 2007
1712
1136
20
Default

Quote:
Originally Posted by drevill View Post
We just tried watching Sound of Music on a BD-350 today, and it would not load. We were able to watch it via my laptop (and HDMI hookup) though, so at least I can confirm the disc isn't defective.
Afterwards I tried leaving the disc in the Sony machine again, and after 12 mins it would not load. No error messages popped up though.
The firmware is up to date, and I have tried other discs, and no issues (yet). Anyone else have this problem with Sound of Music?
Since it's a Fox disc, did you try turning off BD-Live and clearing the persistent memory on the player?
  Reply With Quote
Old 01-06-2013, 12:01 AM   #59
drevill drevill is offline
Junior Member
 
May 2010
Canada
543
38
Default

Quote:
Originally Posted by rdodolak View Post
Since it's a Fox disc, did you try turning off BD-Live and clearing the persistent memory on the player?
Awesome! Thanks. It's working now. I ended up removing the thumb drive completely. I don't even use BD-Live regularly, so it's turned off now.
  Reply With Quote
Old 01-08-2013, 12:25 AM   #60
samiam66 samiam66 is offline
New Member
 
Jan 2013
Default Problem fixed!!!

Hey guys,

I was having the same problem with the s360. I just followed the instructions of the guy who disassembled his machine and cleaned the lasers with rubbing alcohol. I did exactly the same and it now works perfectly. The discs that wouldn't play now play perfectly! I am a happy camper!
  Reply With Quote
Reply
Go Back   Blu-ray Forum > Blu-ray > Blu-ray Players and Recorders

Similar Threads
thread Forum Thread Starter Replies Last Post
Sony BDP-S350 (judder problems) Blu-ray Players and Recorders sonyman1975 1 03-02-2009 02:27 PM
Sony XBR3 & Sony BDP-s350 PROBLEMS. Need some help Home Theater General Discussion Imgreenlantern 3 11-26-2008 05:04 PM
Problems Creating a FIRMWARE DISC for Sony BDP-S350 Blu-ray Players and Recorders Roland1919 0 07-28-2008 07:45 PM
Sony Bdp-s350 And Bdp-s550 (twice Info Article) Blu-ray Players and Recorders HDTV1080P 7 07-19-2008 01:50 PM
Sony announces players BDP-S350 and BDP-S550 Blu-ray Players and Recorders Grubert 32 02-27-2008 04:43 AM


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 03:20 AM.