Best 4K Blu-ray Deals

Best Blu-ray Movie Deals, See All the Deals »
Top deals | Price drops  
 All countries United States United Kingdom Canada Germany France Spain Italy Japan
The Martian 4K (Blu-ray)
$12.93
Wonder Woman 4K (Blu-ray)
$29.96
The Mummy Trilogy 4K (Blu-ray)
$39.99
Kong: Skull Island 4K (Blu-ray)
$29.96
Logan 4K (Blu-ray)
$19.99
Life 4K (Blu-ray)
$27.99
Power Rangers 4K (Blu-ray)
$24.99
The Revenant 4K (Blu-ray)
$15.22
Deadpool 4K (Blu-ray)
$15.07
Smurfs: The Lost Village 4K (Blu-ray)
$27.96
Planet Earth II 4K (Blu-ray)
$34.99
Ghostbusters 4K + 3D (Blu-ray)
$14.99
What's your next favorite movie?
Join our movie community to find out


Image from: Life of Pi (2012)

Go Back   Blu-ray Forum > Ultra HD Blu-ray and 4K > Ultra HD Blu-ray and 4K Hardware and Technology


Reply
 
Thread Tools Display Modes
Old 06-18-2017, 10:52 AM   #3321
KenHurd KenHurd is online now
Special Member
 
KenHurd's Avatar
 
May 2008
Birmingham, AL
1545
620
461
7
Default

Quote:
Originally Posted by JohnAV View Post
So much for that thought. A bit of tinkering, initially it was default 150 nits, not 300 nits. If you had a OLED and was using HDR -> SDR conversion you would want a lower value. Samsung likely ok with 300 nits. Still the UHD playback seems like a setting is incorrect. If you are getting a lot of artifacts with blacks, maybe Ken needs to change color space from Auto to 4:2:2?

FAQ has the recommended settings as
HDR: Auto, Output Resolution: Custom, Custom Resolution: UHD Auto, Color Space: 4:2:2, Color Depth: Auto, 3D Output: Auto, DVD 24p Conversion: On, in a dual HDMI configuration.
I changed the Color Space to 4:2:2, and it still showed the artifacts in the dark scenes. One thing that I did notice, while it was set to Auto, the Color Space displayed as 4:4:4 when I pressed the Info button. What's the difference between those two?

I've been using this player since February, and this is the first time I've noticed this. It's possible that it could be those three discs, but I will check a different disc that I have watched before, and see if I notice any artifacts. I also recently updated to the latest firmware and reset the default settings and storage.
  Reply With Quote
Old 06-21-2017, 07:10 PM   #3322
ray0414 ray0414 is offline
Blu-ray Guru
 
Oct 2015
Michigan, USA
3
Default

Not sure if this is good or bad but... With oppo at all zeros my 4k movies look soft. But bumping up to +3 really makes them look native 4k or close to it. It's like a darbee effect with really excellent edge enhancement. I don't even see any sharpening artifacts either.
65KS9800: 1500 peak nits. 96%DCI. HDR10 support.
  Reply With Quote
Old 06-21-2017, 10:56 PM   #3323
JohnAV JohnAV is offline
Blu-ray Guru
 
JohnAV's Avatar
 
Sep 2009
SF Bay area - Oppo Beta Tester
566
29
2
Default

Quote:
Originally Posted by ray0414 View Post
Not sure if this is good or bad but... With oppo at all zeros my 4k movies look soft. But bumping up to +3 really makes them look native 4k or close to it. It's like a darbee effect with really excellent edge enhancement. I don't even see any sharpening artifacts either.
Your still using KS9800 with this observation? I like your AVS comment:

Quote:
Coming from a 103d, I finally feel at rest without having darbee or the vrs chip for the amazing edge enhancement ability it had.
  Reply With Quote
Old Yesterday, 04:48 AM   #3324
pbz06 pbz06 is offline
Active Member
 
Nov 2009
387
Default

Quote:
Originally Posted by ray0414 View Post
Not sure if this is good or bad but... With oppo at all zeros my 4k movies look soft. But bumping up to +3 really makes them look native 4k or close to it. It's like a darbee effect with really excellent edge enhancement. I don't even see any sharpening artifacts either.
I don't know, the Oppo at 0 looks really sharp to me. No need to add enhancement. I have a Z9D. When I had the ub900, I spent days testing and comparing shots and never bought into the sharpness debate.
  Reply With Quote
Old Yesterday, 05:38 AM   #3325
ray0414 ray0414 is offline
Blu-ray Guru
 
Oct 2015
Michigan, USA
3
Default

Quote:
Originally Posted by JohnAV View Post
Your still using KS9800 with this observation? I like your AVS comment:


Yes I am.

Quote:
Originally Posted by pbz06 View Post
I don't know, the Oppo at 0 looks really sharp to me. No need to add enhancement. I have a Z9D. When I had the ub900, I spent days testing and comparing shots and never bought into the sharpness debate.


Sony has the best processing. and the Z is pretty sharp as it is. That's why you see it differently.
65KS9800: 1500 peak nits. 96%DCI. HDR10 support.
  Reply With Quote
Old Yesterday, 09:36 AM   #3326
Geoff D Geoff D is offline
Blu-ray Archduke
 
Geoff D's Avatar
 
Feb 2009
Swanage, Engerland
1136
1
5
10
Default

That's the thing, coming from a Darbee'd perspective then the vanilla OPPO output is bound to look a bit soft.

The thing about Sony's base 4K processing is that it's so good because it doesn't fudge with the picture much at all, as even with the X1E processor Sony's still can't alter the aspect ratio of 3840x2160 signals for example, and the sharpening control in 4K only has a very, very mild effect. The 14-bit oversampling is there on the newer models for 4K Smooth Gradation, fair enough, and they've boosted the power of the Reality Creation in 4K too, but if you don't start tweaking all the special sauce settings then the Sony's underlying processing will give a nice unmolested image.
  Reply With Quote
Thanks given by:
pbz06 (Yesterday)
Old Yesterday, 12:25 PM   #3327
Paradigmfinatic Paradigmfinatic is offline
Junior Member
 
Jun 2017
Ohio
5
Default

Just FYI, A couple of new issues with Oppo 203 - This is not hate mail or poking - I am sure FW updates in future will resolve

I had John Wick Chapter 2 4K UHD freeze up and stop play about 3/4 way through the movie, stopped movie, pulled up movie on menu and hit resume, still stuck, had to stop movie and pull it out of Oppo and fast forward to scene where it froze, it acted really goofy for a minute and then finally it started to finish the movie -

Another issue i found was when watching Dr. Strange - 7.1 sound **this is not 4K UHD - Disney should have releasesd this one in 4K great movie, the problem with this blu ray while playing on the Oppo i was getting some weird screeching noises from the left surround and left rear overhead height speaker, i have watched this blu ray on my Panasonic 4K player both 3D and Blu Ray version and never experienced this issue.
  Reply With Quote
Old Yesterday, 02:06 PM   #3328
Talon884 Talon884 is offline
Blu-ray Champion
 
Talon884's Avatar
 
Oct 2010
Sarasota, FL
395
Default

Quote:
Originally Posted by Paradigmfinatic View Post
Just FYI, A couple of new issues with Oppo 203 - This is not hate mail or poking - I am sure FW updates in future will resolve

I had John Wick Chapter 2 4K UHD freeze up and stop play about 3/4 way through the movie, stopped movie, pulled up movie on menu and hit resume, still stuck, had to stop movie and pull it out of Oppo and fast forward to scene where it froze, it acted really goofy for a minute and then finally it started to finish the movie -

Another issue i found was when watching Dr. Strange - 7.1 sound **this is not 4K UHD - Disney should have releasesd this one in 4K great movie, the problem with this blu ray while playing on the Oppo i was getting some weird screeching noises from the left surround and left rear overhead height speaker, i have watched this blu ray on my Panasonic 4K player both 3D and Blu Ray version and never experienced this issue.
I have both of these movies and have watched each multiple times and never an issue ... sorry to hear about your problems
Talon884
Sarasota, FL.

LG OLED 65E6P | Marantz AV7703 | Marantz M7055 | XLR interconnects | OPPO UHDP 203 | PS3 | Nintendo NES | Atari 2600 | Roku Premiere + | Klipsch | Monster Power HD 2550
  Reply With Quote
Old Yesterday, 06:12 PM   #3329
Tns49 Tns49 is offline
Expert Member
 
Mar 2011
4
2338
315
13
Default

Quote:
Originally Posted by Paradigmfinatic View Post
Just FYI, A couple of new issues with Oppo 203 - This is not hate mail or poking - I am sure FW updates in future will resolve

I had John Wick Chapter 2 4K UHD freeze up and stop play about 3/4 way through the movie, stopped movie, pulled up movie on menu and hit resume, still stuck, had to stop movie and pull it out of Oppo and fast forward to scene where it froze, it acted really goofy for a minute and then finally it started to finish the movie -

Another issue i found was when watching Dr. Strange - 7.1 sound **this is not 4K UHD - Disney should have releasesd this one in 4K great movie, the problem with this blu ray while playing on the Oppo i was getting some weird screeching noises from the left surround and left rear overhead height speaker, i have watched this blu ray on my Panasonic 4K player both 3D and Blu Ray version and never experienced this issue.
I don't have JW 2, but I and a few others, had problems at a similar problem with JW 1. Turned out to be smudges on disk surface near outer edge.


I had no problem with Dr. Strange. But I bitstream. Are you bitstreaming or using the OPPO's digital to analog converters?
  Reply With Quote
Old Yesterday, 06:41 PM   #3330
Paradigmfinatic Paradigmfinatic is offline
Junior Member
 
Jun 2017
Ohio
5
Default

JW2 was brand new out of the case, not a flaw or fingerprint on it

I have the Oppo 203 HDMI connected straight to the OLED TV via HDMI and the Audio HDMI out directly to my Morantz receiver - This was so Dolby Vision could pass straight to the OLED - The panasonic has the one HDMI going straight to the receiver and then output from receiver to OLED

Again, this is not a bashing or complaint with Oppo 203 i have one now, I am sure there are still some subtle fixes with FW updates that will happen,

Note: I played DM1 and DM2 no issues start to finish playing in Dolby Vision, had trouble getting the DTS X to follow suit but figured that out after a post here and fast response
  Reply With Quote
Old Yesterday, 07:57 PM   #3331
JimShaw JimShaw is offline
Blu-ray Samurai
 
JimShaw's Avatar
 
Jul 2008
Menifee, CA
793
109
Default

Have a new JW2 4K in a 203 connected to a DenonX7200WA

Played twice and on both occasions, there was a slight hiccup about 2/3 thirds way through the movie.

Maybe I should watch it again to see if it happens the third time




\.
8.3 Surround, protected by APC H15 & UPS BC750G
Speakers: SpeakerCraft: 6 AIM8 Fives & 2 TIME Fives used as Wides
Woofers: SVS PB13-Ultra (1), HSU MBM-12 MK2 (2)
TV: Samsung UN78JS9500, LG OLED55E6P
Oppo UHD-203 player, Denon X7200WA, Harmony 1100, Harmony Elite, 9 Noctua cooling fans
  Reply With Quote
Old Yesterday, 08:04 PM   #3332
HiDefBer HiDefBer is offline
Member
 
HiDefBer's Avatar
 
Aug 2009
Default

I wonder what the next "big" update for the 203 will bring now that DV has been added. Or have we entered "fine tuning" territory with only minor tweaks here and there?
  Reply With Quote
Thanks given by:
RageATL (Yesterday)
Old Yesterday, 08:41 PM   #3333
LordoftheRings LordoftheRings is offline
Special Member
 
LordoftheRings's Avatar
 
Mar 2010
Portishead ♫
Default

Quote:
Originally Posted by Paradigmfinatic View Post
Just FYI, A couple of new issues with Oppo 203 - This is not hate mail or poking - I am sure FW updates in future will resolve

I had John Wick Chapter 2 4K UHD freeze up and stop play about 3/4 way through the movie, stopped movie, pulled up movie on menu and hit resume, still stuck, had to stop movie and pull it out of Oppo and fast forward to scene where it froze, it acted really goofy for a minute and then finally it started to finish the movie -

Another issue i found was when watching Dr. Strange - 7.1 sound **this is not 4K UHD - Disney should have released this one in 4K great movie, the problem with this blu ray while playing on the Oppo i was getting some weird screeching noises from the left surround and left rear overhead height speaker, i have watched this blu ray on my Panasonic 4K player both 3D and Blu Ray version and never experienced this issue.
Quote:
Originally Posted by JimShaw View Post
Have a new JW2 4K in a 203 connected to a DenonX7200WA

Played twice and on both occasions, there was a slight hiccup about 2/3 thirds way through the movie.

Maybe I should watch it again to see if it happens the third time
John Wick: Chapter 2 on 4K BR is a BD-100 - layer change.
______

FYI, when people described some 203's issues it is not bashing, nobody is going to ban you for life. It helps Oppo @ improving their players; so it's a positive.
______

How is the HDMI Input on the 203 since the last firmware update?
~ Bob
You may not: Restrict or inhibit any other user from using and enjoying the Web Sites.
  Reply With Quote
Old Yesterday, 09:03 PM   #3334
cleeve cleeve is offline
Member
 
Feb 2010
Default

Quote:
Originally Posted by HiDefBer View Post
I wonder what the next "big" update for the 203 will bring now that DV has been added. Or have we entered "fine tuning" territory with only minor tweaks here and there?
With the sharpness slider taking care of the "soft picture" complaints that a few had, and DV arriving as promised, there's not really room for any big updates. I'd imagine just further bug fixes and compatibility updates from here.
Samsung 55" 4K KS8000
Oppo UDP-203
Sony STR-DN1040
Paradigm Atom v7
  Reply With Quote
Old Yesterday, 09:41 PM   #3335
gkolb gkolb is offline
Senior Member
 
gkolb's Avatar
 
Feb 2012
Bakersfield, CA
151
2
Default

If they update the HDMI-in to 2.0 a or b for HDR (and HLG and DV), I think many will see that as a BIG update !
  Reply With Quote
Old Yesterday, 09:45 PM   #3336
kristoffer kristoffer is offline
Blu-ray Samurai
 
kristoffer's Avatar
 
May 2010
Denmark
Default

Quote:
Originally Posted by HiDefBer View Post
I wonder what the next "big" update for the 203 will bring now that DV has been added. Or have we entered "fine tuning" territory with only minor tweaks here and there?


Apps?
Hands off the compression button, Music Industry!
Hands off the DNR button, Blu-Ray producers!
Films are supposed to have grain!

https://twitter.com/Kristofferabild
  Reply With Quote
Old Yesterday, 09:59 PM   #3337
mutelight mutelight is offline
Active Member
 
mutelight's Avatar
 
Jan 2009
SF Bay Area, CA
18
149
Default

Quote:
Originally Posted by JimShaw View Post
Have a new JW2 4K in a 203 connected to a DenonX7200WA

Played twice and on both occasions, there was a slight hiccup about 2/3 thirds way through the movie.

Maybe I should watch it again to see if it happens the third time
I only watched it once and I locked up about 2/3 of the way through. I had to completely stop the movie and resume it.

The last time I had any issue was with Deepwater Horizon and some stutters, otherwise all my other movies have been perfectly fine. (And they released an update to fix that specific title.)
  Reply With Quote
Old Today, 07:08 AM   #3338
d514 d514 is offline
Senior Member
 
May 2010
Germany
1
Default

Quote:
Originally Posted by LordoftheRings View Post
John Wick: Chapter 2 on 4K BR is a BD-100 - layer change.
There shouldn't be any visible or audible layer change with Blu-ray or UHD Blu-ray. This isn't DVD.
Samsung KS7090 65" (German version of the KS8000), Panasonic UB704 Multiregion, Onkyo TX-NR555, KEF Q5, Q1, Q9C
My Blu-ray/DVD Collection
  Reply With Quote
Reply
Go Back   Blu-ray Forum > Ultra HD Blu-ray and 4K > Ultra HD Blu-ray and 4K Hardware and Technology


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 10:29 AM.