Best Blu-ray Deals

Best Blu-ray Deals, See All the Deals »
Top deals | Price drops  
 All countries United States United Kingdom Canada Germany France Spain Italy Japan
Big (Blu-ray)
$7.99
The Americans: The Complete First Season (Blu-ray)
$24.99
Hugo (Blu-ray)
$4.99
Gatchaman: Complete Collection + OVAs (Blu-ray)
$59.99
Frozen Planet (Blu-ray)
$14.99
Slap Shot (Blu-ray)
$9.96
Uncle Buck (Blu-ray)
$6.96
Animal House (Blu-ray)
$9.96
The Simpsons: The Sixteenth Season (Blu-ray)
$19.99
Seven (Blu-ray)
$4.99
Grease (Blu-ray)
$4.99
Grave of the Fireflies (Blu-ray)
$12.99
The Forbidden Kingdom (Blu-ray)
$5.00
Mallrats (Blu-ray)
$9.96
Far and Away (Blu-ray)
$10.49
Fairy Tail: Part 8 (Blu-ray)
$26.99
Godzilla (Blu-ray)
$19.99
Somewhere in Time (Blu-ray)
$10.49
High School of the Dead OVA: Drifters of the Dead (Blu-ray)
$4.99

Go Back   Blu-ray Forum > Blu-ray > Blu-ray Players and Recorders

Reply
 
Thread Tools Display Modes
Old 08-05-2012, 05:51 PM   #1
bluskies bluskies is offline
Blu-ray Samurai
 
bluskies's Avatar
 
Oct 2007
1335
248
72
Default Panasonic 310 sound but no picture on region-free UK Sherlock titles

I have a Panasonic 310 Blu player and I have found that it has played various UK region-free titles before with no problem, but in trying to play Sherlock series one or two, all I get is the sound, but no picture. The really weird thing is I get text showing (such as the main menu) but still no picture. I tested other Blus (U.S.) in it and they display the picture fine.

I just tried the 1.88 update but no change.

Anyone have any ideas?
  Reply With Quote
Old 08-05-2012, 06:25 PM   #2
pentatonic pentatonic is offline
Blu-ray Ninja
 
pentatonic's Avatar
 
Jan 2009
Montreal, Canada
569
6
158
Default

Quote:
Originally Posted by bluskies View Post
I have a Panasonic 310 Blu player and I have found that it has played various UK region-free titles before with no problem, but in trying to play Sherlock series one or two, all I get is the sound, but no picture. The really weird thing is I get text showing (such as the main menu) but still no picture. I tested other Blus (U.S.) in it and they display the picture fine.

I just tried the 1.88 update but no change.

Anyone have any ideas?
From what I see they are region free but 1080i50 which I guess your player can't accept (to be verified but my guess)
  Reply With Quote
Old 08-05-2012, 07:00 PM   #3
Tech-UK Tech-UK is offline
Blu-ray Samurai
 
Tech-UK's Avatar
 
Sep 2010
UK
78
329
22
Default

Quote:
Originally Posted by pentatonic View Post
From what I see they are region free but 1080i50 which I guess your player can't accept (to be verified but my guess)
Yep Sherlock season 1 and 2 are both 1080i50.
Blu-ray Wishlist: True Lies | The Abyss | Midnight Run | Bad Boys II | Balls of Fury | Over The Hedge | Twins | Ghostbusters II
  Reply With Quote
Old 12-01-2012, 12:38 AM   #4
digs5446 digs5446 is offline
Active Member
 
Nov 2008
Default

So what's the point of it being "region free" if you can't actually PLAY IT? I just got this for me and my Dad (his birthday present) and he just called me up saying it wouldn't play. Talk about embarrassing.
  Reply With Quote
Reply
Go Back   Blu-ray Forum > Blu-ray > Blu-ray Players and Recorders


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 03:44 AM.