Best Blu-ray Deals

Best Blu-ray Deals, See All the Deals »
Top deals | Price drops  
 All countries United States United Kingdom Canada Germany France Spain Italy Japan
Continuum: Season Two (Blu-ray)
$12.99
The Rose (Blu-ray)
$22.99
Sullivanís Travels (Blu-ray)
$22.99
American Horror Story: Asylum (Blu-ray)
$19.99
The Life Aquatic with Steve Zissou (Blu-ray)
$19.99
Continuum: Season One (Blu-ray)
$12.99
Homeland: The Complete First Season (Blu-ray)
$19.99
Fantastic Mr. Fox (Blu-ray)
$19.99
Bates Motel: Season Two (Blu-ray)
$19.99
Legend of the Guardians: The Owls of Ga'Hoole / Hugo (Blu-ray)
$19.99
Harry Potter and the Deathly Hallows: Parts 1 & 2 3D (Blu-ray)
$19.99
Clash of the Titans 3D / Wrath of the Titans 3D (Blu-ray)
$19.99
COLLECT WATCH TRACK RATE REVIEW APP
Manage your own movie collection and always keep it with you with our Apps. Price track movies and get price drop notifications instantly. Become a member to take full advantage of all site features.
GET STARTED

Go Back   Blu-ray Forum > Audio > Audio Theory and Discussion

Reply
 
Thread Tools Display Modes
Old 05-29-2013, 04:03 AM   #21
OneWayFilms OneWayFilms is offline
Blu-ray Guru
 
OneWayFilms's Avatar
 
Mar 2010
USA
506
304
2
Default

Quote:
Originally Posted by BIslander View Post
Stereo is not surround. It's just 2 channels.

Sent from my HTC6435LVW using Tapatalk 2
I agree, and I don't know how to explain it, but the back speakers still work.
  Reply With Quote
Old 05-29-2013, 04:42 AM   #22
BIslander BIslander is offline
Blu-ray Samurai
 
BIslander's Avatar
 
Sep 2008
Bainbridge Island, WA
Default

Maybe you've selected multichannel stereo.
  Reply With Quote
Old 01-19-2014, 02:04 AM   #23
Da Frogs Da Frogs is offline
New Member
 
Jan 2014
Default 360 sound problems

I am having trouble with my blu ray sound. I have a Sony s360 and the sound is only coming out of 1 speaker and it's muffled. I have tried to reset to the factory. I've also tried the audio drc to tv mode and the output priority to HDMI. I run the sound through my stereo and have had no trouble for 3 years up until now. I recently did a network update and I'm wondering if that caused a problem. Any ideas how to fix?
  Reply With Quote
Old 01-19-2014, 02:05 AM   #24
BIslander BIslander is offline
Blu-ray Samurai
 
BIslander's Avatar
 
Sep 2008
Bainbridge Island, WA
Default

How are your devices connected and what is the Blu-ray audio output format?
  Reply With Quote
Old 01-19-2014, 02:51 AM   #25
DavePS3 DavePS3 is offline
Blu-ray Guru
 
DavePS3's Avatar
 
Jan 2007
Toronto
47
1
Default

These issues are usually caused by problems in the receiver. If you take the HDMI and by-pass the receiver... taking the HDMI straight to the TV, I bet you wont have any drop out issues in the audio. Likewise, if you take the Toslink (Fiber optic) from the player to the optical input on the receiver, the issues will vanish I bet. It's a problem in the HDMI board in the receiver but also try another HDMI input on the receiver. If it's still bad, the input board is the problem rather than just one input.
2747 titles on disc... of those, 17 are LaserDisc, 1115 are Blu-Ray, 94 are in 3D & 4 are BluRay Audio. My avatar shot was just taken last September with a 200.00 Nikon set on timer. Shows what a cheap camera can do.
  Reply With Quote
Old 01-19-2014, 06:33 PM   #26
Da Frogs Da Frogs is offline
New Member
 
Jan 2014
Default

Thanks for the replies. I am old school. My Blu Ray has HDMI but also has rca red and white cable output to my very old receiver. My receiver still works fine for my normal cable box so I really don't think it's the receiver. When I go directly to my tv through HDMI, the sound is ok so I am thinking it's something to do with the sound output through the rca plugs.
  Reply With Quote
Old 02-02-2014, 05:39 AM   #27
KevinW KevinW is offline
Member
 
KevinW's Avatar
 
Sep 2010
873
58
7
Default

I just bought Pacific Rim and am having the same problem. The audio cuts out on certain spots and I tried playing it on another blu ray player and it works fine. I just bought the Sony blu ray player like a month ago too. Not sure what the problem is since I haven't had this problem with any other movies yet.
  Reply With Quote
Reply
Go Back   Blu-ray Forum > Audio > Audio Theory and Discussion


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 07:03 AM.