Best Blu-ray Deals

Black Friday Sale is Live, $3.99 Blu-ray Movies »
Now: Mad Men: The Final Season, Part 1 $10.00 (32% sold out)
Now: Neighbors $9.00 (26% sold out)
Now: Mission: Impossible - Ghost Pr… $3.96 (25% sold out)
Top deals | Price drops  
 All countries United States United Kingdom Canada Germany France Spain Italy Japan
Killing Them Softly (Blu-ray)
$3.99
8 hrs ago
Gangs of New York (Blu-ray)
$3.99
45 min ago
American Hustle (Blu-ray)
$6.00
20 hrs ago
The Sandlot (Blu-ray)
$4.99
1 hr ago
The Good, the Bad and the Ugly (Blu-ray)
$4.99
11 hrs ago
Breaking Bad: The Final Season (Blu-ray)
$9.99
14 hrs ago
Good Will Hunting (Blu-ray)
$3.99
23 hrs ago
Act of Valor (Blu-ray)
$4.99
1 hr ago
The Hobbit: The Desolation of Smaug (Blu-ray)
$9.00
19 hrs ago
Super 8 (Blu-ray)
$4.99
23 hrs ago
X-Men: Days of Future Past (Blu-ray)
$9.99
14 hrs ago
Frozen Planet (Blu-ray)
$9.99
13 hrs ago
A Million Ways to Die in the West (Blu-ray)
$9.00
22 hrs ago
Bad Santa (Blu-ray)
$3.99
15 hrs ago

Go Back   Blu-ray Forum > Blu-ray > Blu-ray Players and Recorders

Reply
 
Thread Tools Display Modes
Old 08-05-2012, 06:51 PM   #1
bluskies bluskies is offline
Blu-ray Samurai
 
bluskies's Avatar
 
Oct 2007
1460
248
72
Default Panasonic 310 sound but no picture on region-free UK Sherlock titles

I have a Panasonic 310 Blu player and I have found that it has played various UK region-free titles before with no problem, but in trying to play Sherlock series one or two, all I get is the sound, but no picture. The really weird thing is I get text showing (such as the main menu) but still no picture. I tested other Blus (U.S.) in it and they display the picture fine.

I just tried the 1.88 update but no change.

Anyone have any ideas?
  Reply With Quote
Old 08-05-2012, 07:25 PM   #2
pentatonic pentatonic is offline
Blu-ray Ninja
 
pentatonic's Avatar
 
Jan 2009
Montreal, Canada
569
1
6
158
Default

Quote:
Originally Posted by bluskies View Post
I have a Panasonic 310 Blu player and I have found that it has played various UK region-free titles before with no problem, but in trying to play Sherlock series one or two, all I get is the sound, but no picture. The really weird thing is I get text showing (such as the main menu) but still no picture. I tested other Blus (U.S.) in it and they display the picture fine.

I just tried the 1.88 update but no change.

Anyone have any ideas?
From what I see they are region free but 1080i50 which I guess your player can't accept (to be verified but my guess)
  Reply With Quote
Old 08-05-2012, 08:00 PM   #3
Tech-UK Tech-UK is offline
Blu-ray Samurai
 
Tech-UK's Avatar
 
Sep 2010
UK
81
349
22
Default

Quote:
Originally Posted by pentatonic View Post
From what I see they are region free but 1080i50 which I guess your player can't accept (to be verified but my guess)
Yep Sherlock season 1 and 2 are both 1080i50.
Selling my Disneynature collection. Click HERE.
  Reply With Quote
Old 12-01-2012, 01:38 AM   #4
digs5446 digs5446 is offline
Active Member
 
Nov 2008
Worcester, MA, USA
Default

So what's the point of it being "region free" if you can't actually PLAY IT? I just got this for me and my Dad (his birthday present) and he just called me up saying it wouldn't play. Talk about embarrassing.
  Reply With Quote
Reply
Go Back   Blu-ray Forum > Blu-ray > Blu-ray Players and Recorders


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 08:32 AM.