Best Blu-ray Deals

Best Blu-ray Deals, See All the Deals »
Top deals | Price drops  
 All countries United States United Kingdom Canada Germany France Spain Italy Japan
Attack on Titan Part 2 Limited Edition (Blu-ray)
$51.79
Star Trek: The Compendium (Blu-ray)
$24.96
Mad Men: The Final Season, Part 1 (Blu-ray)
$19.99
Wrong Turn Trilogy (Blu-ray)
$9.99
Fate/Stay Night: Complete Collection (Blu-ray)
$54.99
Attack on Titan Part 2 (Blu-ray)
$24.97
Willow (Blu-ray)
$11.12
Masterpiece: Downton Abbey Seasons 1 - 4 (Blu-ray)
$44.99
The Dick Van Dyke Show: The Complete Series (Blu-ray)
$57.99
Sons of Anarchy: Seasons 1-6 (Blu-ray)
$172.59
White Christmas (Blu-ray)
$18.69
How to Train Your Dragon (Blu-ray)
$12.96
Nekromantik (Blu-ray)
$20.19
Chucky: The Complete Collection (Blu-ray)
$31.99
The Simpsons: The Seventeenth Season (Blu-ray)
$29.96
Woodstock: 3 Days of Peace & Music (Blu-ray)
$17.99
COLLECT WATCH TRACK RATE REVIEW APP
Manage your own movie collection and always keep it with you with our Apps. Price track movies and get price drop notifications instantly. Become a member to take full advantage of all site features.
GET STARTED

Go Back   Blu-ray Forum > Blu-ray > Blu-ray Technology and Future Technology

Reply
 
Thread Tools Display Modes
Old 09-18-2010, 05:03 AM   #1
soxfan5634 soxfan5634 is offline
Junior Member
 
soxfan5634's Avatar
 
Aug 2010
175
1
Default Older Lionsgate Titles Won't Play Anymore?

Has anyone else had an issue with this? The only one that doesn't work anymore is Devils Rejects, and I've tried 4 copies of it. It used to work just fine. I know I saw someone else mention it in another thread about Basic Instinct but I wanna see if we can get this solved. The discs I've tried take like 15 min just to load up, then they won't play.

For those who do have the PS3 and some older titles, try them and see if they work.
  Reply With Quote
Old 09-18-2010, 05:10 AM   #2
nolfoc nolfoc is offline
Banned
 
Nov 2008
-
109
49
Default

Quote:
Originally Posted by soxfan5634 View Post
Has anyone else had an issue with this? The only one that doesn't work anymore is Devils Rejects, and I've tried 4 copies of it. It used to work just fine. I know I saw someone else mention it in another thread about Basic Instinct but I wanna see if we can get this solved. The discs I've tried take like 15 min just to load up, then they won't play.

For those who do have the PS3 and some older titles, try them and see if they work.
i have no problems on my sony BD550 i actually watched Rambo First Blood Part II last week just fine.. see if theirs a firmware upgrade
  Reply With Quote
Old 09-18-2010, 05:12 AM   #3
RAZGRIZ-1 RAZGRIZ-1 is offline
Blu-ray Guru
 
RAZGRIZ-1's Avatar
 
May 2008
Illinois
1
230
5
Default

All of my Lionsgate Blu's work fine.
  Reply With Quote
Old 09-18-2010, 05:23 AM   #4
soxfan5634 soxfan5634 is offline
Junior Member
 
soxfan5634's Avatar
 
Aug 2010
175
1
Default

Quote:
Originally Posted by nolfoc View Post
i have no problems on my sony BD550 i actually watched Rambo First Blood Part II last week just fine.. see if theirs a firmware upgrade
I have the most current firmware. It's strange because I've had a copy of Devils Rejects for years, and just recently it stopped playing. I've exchanged it for 3 different copies now at Wally World, and none of em played. Everything other than that works perfectly. My first thought was that somehow the firmware screwed around with it, but even as i downloaded the newest, it still wouldn't work. So i have no idea why this one movie wont play anymore.
  Reply With Quote
Old 09-18-2010, 05:51 AM   #5
Marine Mike Marine Mike is offline
The Busey
 
Marine Mike's Avatar
 
Apr 2008
Ohio
7
120
4
4
Default

I've had this problem before. To fix it I replaced the laser in my PS3.
"The word fan is an obsolete word to me. It means two thing: fantastic or fanatic. Or something that hangs on a ceiling or sits on a table and blows wind in your face." - Gary Busey
  Reply With Quote
Old 09-18-2010, 06:38 AM   #6
nolfoc nolfoc is offline
Banned
 
Nov 2008
-
109
49
Default

Quote:
Originally Posted by soxfan5634 View Post
I have the most current firmware. It's strange because I've had a copy of Devils Rejects for years, and just recently it stopped playing. I've exchanged it for 3 different copies now at Wally World, and none of em played. Everything other than that works perfectly. My first thought was that somehow the firmware screwed around with it, but even as i downloaded the newest, it still wouldn't work. So i have no idea why this one movie wont play anymore.
its probably your PS3
  Reply With Quote
Old 09-18-2010, 07:06 AM   #7
soxfan5634 soxfan5634 is offline
Junior Member
 
soxfan5634's Avatar
 
Aug 2010
175
1
Default

Quote:
Originally Posted by nolfoc View Post
its probably your PS3
Forgot to mention, I tried 2 copies on a friends ps3 as well, same problem. Unless its just a coincidence that both of our ps3's decided to go "bad" at the exact same time and stop reading this one movie...its just hard to make sense of it, because it works perfectly otherwise.
  Reply With Quote
Old 09-18-2010, 10:05 AM   #8
TheWildWhelk TheWildWhelk is offline
Power Member
 
TheWildWhelk's Avatar
 
Oct 2007
Dunsfold
63
4
Default

No problems with the region-free rambo Trilogy (i.e the original BD releases). Was going to say that Terminator 2 Skynet Edition takes blasted ages to load, but that's from Optimum in the UK, and not Lionsgate.
Samsung 3D F6800 40". PS4. 80 Gig PS3. Technika BRSS10 multi-region BD player.
  Reply With Quote
Old 09-18-2010, 10:54 AM   #9
DavePS3 DavePS3 is offline
Blu-ray Guru
 
DavePS3's Avatar
 
Jan 2007
Toronto
47
1
Default

Try turning the auto' BD LIVE off, then pop the disc back in. See if that helps. It used to on some older titles.
2695 titles on disc... of those, 17 are LaserDisc, 1067 are Blu-Ray, 80 are in 3D. My avatar shot was just taken last September with a 200.00 Nikon. Shows what a cheap camera can do.
  Reply With Quote
Old 09-20-2010, 10:31 PM   #10
soxfan5634 soxfan5634 is offline
Junior Member
 
soxfan5634's Avatar
 
Aug 2010
175
1
Default

Quote:
Originally Posted by DavePS3 View Post
Try turning the auto' BD LIVE off, then pop the disc back in. See if that helps. It used to on some older titles.
Where can I find this 'auto BD Live off' option?
  Reply With Quote
Old 09-20-2010, 11:50 PM   #11
bluflu bluflu is offline
Special Member
 
bluflu's Avatar
 
Mar 2007
Default

Quote:
Originally Posted by soxfan5634 View Post
Where can I find this 'auto BD Live off' option?
Settings > Video Settings > BD internet connection > Confirm.
  Reply With Quote
Old 09-20-2010, 11:55 PM   #12
bluflu bluflu is offline
Special Member
 
bluflu's Avatar
 
Mar 2007
Default

Just checked and my copy of Devil's rejects and it plays fine in my PS3. I had what you describe happen once with a video game after switching my PS3's output from HDMI to composite video then back again. I had to re-auto adjust my audio settings to get the game to play. I doubt if your problem has anything to do with BD Live since my copy doesn't appear to have BD Live. I bet your PS3 is mis-configured to play the DTS-HD HR soundtrack that's on the disc. Check the following.

Settings > Sound Settings > Audio Output settings > HDMI > Automatic.
  Reply With Quote
Old 09-21-2010, 12:41 AM   #13
soxfan5634 soxfan5634 is offline
Junior Member
 
soxfan5634's Avatar
 
Aug 2010
175
1
Default

Quote:
Originally Posted by bluflu View Post
Just checked and my copy of Devil's rejects and it plays fine in my PS3. I had what you describe happen once with a video game after switching my PS3's output from HDMI to composite video then back again. I had to re-auto adjust my audio settings to get the game to play. I doubt if your problem has anything to do with BD Live since my copy doesn't appear to have BD Live. I bet your PS3 is mis-configured to play the DTS-HD HR soundtrack that's on the disc. Check the following.

Settings > Sound Settings > Audio Output settings > HDMI > Automatic.
Tried it, nothin. Also tried the BD Live thing, nothin there either. It sucks, because Devils Rejects is one of my favorite movies, and I have no idea why it will no longer play on my ps3.
  Reply With Quote
Old 09-21-2010, 01:15 AM   #14
bluflu bluflu is offline
Special Member
 
bluflu's Avatar
 
Mar 2007
Default

Quote:
Originally Posted by soxfan5634 View Post
Tried it, nothin. Also tried the BD Live thing, nothin there either. It sucks, because Devils Rejects is one of my favorite movies, and I have no idea why it will no longer play on my ps3.
I don't know what's left to try, short of restoring all of the default settings to see if it will play through the composite video output. Do you have a direct connection from your PS3 to your TV, or do you go through an amp?
  Reply With Quote
Old 09-21-2010, 01:52 AM   #15
soxfan5634 soxfan5634 is offline
Junior Member
 
soxfan5634's Avatar
 
Aug 2010
175
1
Default

Quote:
Originally Posted by bluflu View Post
I don't know what's left to try, short of restoring all of the default settings to see if it will play through the composite video output. Do you have a direct connection from your PS3 to your TV, or do you go through an amp?
I have it going through a receiver. I just tried connecting it directly to the tv, changing the audio settings, and it still didn't work. I really don't wanna restore it and lose game data, though. Like I said at first, it had worked perfectly until some point this summer. The most logical answer is that it's a bad disc, but after exchanging it for 3 different copies now, you'd think that isn't the case.

Also, I should note that when this problem first started, the disc would take about 15 min to pop up on the XMB, and then I'd still be able to view the movie, although it skipped a few times. Today, the disc still took ~15 min to load, and now it either says "This disc cannot be played" or it just goes to a black screen and freezes there.
  Reply With Quote
Old 09-21-2010, 04:18 AM   #16
bluflu bluflu is offline
Special Member
 
bluflu's Avatar
 
Mar 2007
Default

Quote:
Originally Posted by soxfan5634 View Post
I have it going through a receiver. I just tried connecting it directly to the tv, changing the audio settings, and it still didn't work. I really don't wanna restore it and lose game data, though. Like I said at first, it had worked perfectly until some point this summer. The most logical answer is that it's a bad disc, but after exchanging it for 3 different copies now, you'd think that isn't the case.

Also, I should note that when this problem first started, the disc would take about 15 min to pop up on the XMB, and then I'd still be able to view the movie, although it skipped a few times. Today, the disc still took ~15 min to load, and now it either says "This disc cannot be played" or it just goes to a black screen and freezes there.
I didn't mean the hard drive format complete system restore, I meant "Settings > System Settings > Restore Default Settings". But it sounds like your PS3 possibly has a more serious problem.
  Reply With Quote
Old 09-21-2010, 12:42 PM   #17
soxfan5634 soxfan5634 is offline
Junior Member
 
soxfan5634's Avatar
 
Aug 2010
175
1
Default

Quote:
Originally Posted by bluflu View Post
I didn't mean the hard drive format complete system restore, I meant "Settings > System Settings > Restore Default Settings". But it sounds like your PS3 possibly has a more serious problem.
A while ago I was thinkin it's my ps3, but I'm not so sure yet, mainly because of these 2 things.

1) A year ago or so, I had a copy of Saw IV that started doing the exact same thing. I ordered another copy from Amazon, and it worked perfectly afterwards.

2) Devils Rejects didn't work on my friends ps3 either. Neither of us have problems with anything else, just this one disc.

So, I'm still holding out hope that I've had terrible luck and gotten 4 bad discs in a row (?), but who knows. The 3.50 firmware that came out today didn't change anything, btw.
  Reply With Quote
Old 09-21-2010, 11:22 PM   #18
Agent Bond Agent Bond is offline
Blu-ray Ninja
 
Agent Bond's Avatar
 
Dec 2008
Las Vegas, NV
171
3
Default

Time to get a new PS3.
It's showtime, folks!
  Reply With Quote
Old 10-01-2010, 05:25 PM   #19
soxfan5634 soxfan5634 is offline
Junior Member
 
soxfan5634's Avatar
 
Aug 2010
175
1
Default

Quote:
Originally Posted by Agent Bond View Post
Time to get a new PS3.
Thought I'd go ahead and update this thread.

It wasn't my ps3. Since I had this problem with Saw IV before, and I solved it by getting a copy from Amazon, I figured I'd give it a shot. Got my new copy for TDR's today, and guess what...it works perfectly.

Another reason to hate Walmart. I guess they're selling bad copies of this movie? I'm just happy I got a working one again.
  Reply With Quote
Old 02-12-2011, 05:03 PM   #20
HellBound HellBound is offline
New Member
 
Feb 2011
Default

i see this is an old thread. i'm new here. greetings. im phil. found this post on google and joined. i too am having problems with the devils rejects & house of a 1000 corpses.
i run my blus threw me puter. i run power dvd 10. w7. and have a HL-DT-ST DVDRWBD GBC-H20N.
both movies played fine for awhile and there mint!
i since had a co worker take all my blus and try them on his ps3. they all worked but zombies movies.
one has to assume that this is not my player nor, his.
all other of my collection plays great!
any ideas?
and im from the U.S.A.
respectfully,
phil
  Reply With Quote
Reply
Go Back   Blu-ray Forum > Blu-ray > Blu-ray Technology and Future Technology


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 01:50 PM.