COLLECT WATCH TRACK RATE REVIEW APP
Manage your own movie collection and always keep it with you with our Apps. Price track movies and get price drop notifications instantly. Become a member to take full advantage of all site features.
GET STARTED

Best Blu-ray Deals

Best Blu-ray Deals, See All the Deals »
Top deals | Price drops  
 All countries United States United Kingdom Canada Germany France Spain Italy Japan
The Dick Van Dyke Show: The Complete Series (Blu-ray)
$57.99
The Amazing Spider-Man 2 (Blu-ray)
$64.99
Sleeping Beauty (Blu-ray)
$24.99
South Park: The Complete Seventeenth Season (Blu-ray)
$19.99
Game of Thrones: The Complete Fourth Season (Blu-ray)
$39.96
Dragon Ball Z: Season 9 (Blu-ray)
$24.99
Maleficent (Blu-ray)
$19.99
Lost: The Complete First Season (Blu-ray)
$19.50
Cosmos: A Spacetime Odyssey (Blu-ray)
$29.99
Doctor Who: The Complete Eighth Series (Blu-ray)
$64.96
A Nightmare on Elm Street Collection (Blu-ray)
$29.99
Vikings: The Complete Second Season (Blu-ray)
$24.99
Transformers: Age of Extinction 3D (Blu-ray)
$26.99
24: Live Another Day (Blu-ray)
$29.99
War Horse (Blu-ray)
$9.99
Step Up 3D (Blu-ray)
$9.69
Friday the 13th: The Complete Collection (Blu-ray)
$79.99
Transformers: Age of Extinction (Blu-ray)
$17.99
Chef (Blu-ray)
$19.99

Go Back   Blu-ray Forum > Blu-ray.com > Newbie Discussion

Reply
 
Thread Tools Display Modes
Old 08-15-2011, 06:08 AM   #41
CJHacker CJHacker is offline
Member
 
CJHacker's Avatar
 
Mar 2010
West Fargo, NoDak, USA
4
298
25
Default

Ok, so on my Sony player I was able to get this to work now if I just remove my USB memory stick. The disc complains about needing external memory, but I can continue past this and it appears to play fine. Can anyone else duplicate this?
  Reply With Quote
Old 08-16-2011, 03:53 AM   #42
rdwalter rdwalter is offline
New Member
 
rdwalter's Avatar
 
Jul 2010
Kennesaw, GA
3
2
Default

I had the blank screen issue with my Panasonic BD-85 so I did the BD-Video data erase and that fixed it.
  Reply With Quote
Old 08-28-2011, 11:00 PM   #43
blackmonolith blackmonolith is offline
New Member
 
Aug 2011
Default

Quote:
Originally Posted by mostlyharmless View Post
Same issue as Dfelter. Purchased the 2D blu-ray for use on my Samsung BD-C6900, updated to latest firmware and have nothing but blank black screen. Absolute fail. They really need a digital media consumers rights bill. This is crap.
Same problem, but with a twist. The "Rio" Blu-ray disc did play prior to the latest firmware update for the Samsung BD-C6900. I was running firmware v.1019, and the disc (during pre-menu and menu) played fine. It wasn't until after I updated the firmware to the latest v.1021.2 that the problem as described above started happening to me: stuck with a black screen in Title 0 Chapter 0, with all actions "unavailable."

I have alerted Samsung that it seems their latest update was destructive. They're mailing me a CD of v.1019 so that I can revert until they issue another fix.

***EDIT***

A RESET procedure, like the one described below, worked for the Samsung BD-C6900. I can now play "Rio." With no disc in the tray and the power on, hold down STOP (on the player) for five seconds to initiate reset. This will reset factory settings, but it also acts as a cache-cleaning cobweb shaker.

Last edited by blackmonolith; 08-30-2011 at 03:08 AM.
  Reply With Quote
Old 08-30-2011, 12:27 AM   #44
foxxterra foxxterra is offline
New Member
 
Aug 2011
Default

My copy of RIO would not play and would only show a blank screen. I cleaned out the BD file under video on my Sony Blu-ray player and now it works fine. It is like the Temp internet files on a computer, it needs to be cleaned out every once in awhile. If you need step-by-step instructions for a Sony product call 239-768-7547.
  Reply With Quote
Old 09-02-2011, 05:25 AM   #45
brettallica brettallica is offline
Blu-ray Samurai
 
brettallica's Avatar
 
Nov 2008
Santa Cruz, California
51
79
6
Send a message via AIM to brettallica
Default

Quote:
Originally Posted by foxxterra View Post
My copy of RIO would not play and would only show a blank screen. I cleaned out the BD file under video on my Sony Blu-ray player and now it works fine. It is like the Temp internet files on a computer, it needs to be cleaned out every once in awhile. If you need step-by-step instructions for a Sony product call 239-768-7547.
I had/have a similar issue with my Rio disc. I have an "old" Sony Blu-ray player (as seen in my sig), and when we first popped in the Rio disc, it wouldn't play at all. The player acted like it was reading the disc (you could hear the disc spinning, and the TV looked like there was "something" there, but it was just black), but then nothing would ever show up on the screen, the counter on player's the LCD readout wouldn't do anything, and the movie would just never come on.

I tried the disc in my somewhat newer player in our bedroom (Panasonic DMP-BD60, which is from 2009), and the disc took forever to load, but it did eventually play at least the menus and the Angry Birds preview and all that intro stuff; I didn't stick around for the main feature.

Then I took the disc back down to our main home theater in the living room where this "old" player is, did a bit of Googling, and tried clearing out the cache on our player. That was f-ing tedious by the way, as there was tons of data on there from old movies movies we watched years ago at this point. I'm sure there's a way to clear all of the cache in one fell swoop, but I had to do them individually, as I haven't done any research to see if there's another way. Anyway, I got that all cleared, turned off the player, turned it back on, and then had **some** success. Now, after the cache has been cleared, I can get the menu to come up, and it appears that the disc can be read as it was intended. The thing is, though, it takes FOREVER to load stuff. I mean, it's pretty bad. I had a similar experience in my very short test with my aforementioned Panasonic player, but not to this extreme. The disc loaded very slowly there, too, but this Sony player is really taking its time. Yes, the firmware is up to date, for those who are about to suggest that.

I wonder if this is a combination of old players and a new movie, or just a badly authored disc. I have been thinking about buying new players anyway, and it appears as though this movie may have forced me to do it sooner than I had thought I would need to. I haven't actually tried to play the entire movie yet, so I have no report on the skipping and freezing issues that others are reporting.
TV: Samsung 50" PN50A550 1080p Plasma
Blu-ray Player: Sony BDP-S550 // DVD: Sony RDR-VX515 DVD Recorder/VCR Combo
A/V Receiver: STR-DG920 7.1 Audio/Video Receiver
Speakers: Center Polk CS-1 / Fronts Polk Monitor 60 / Surrounds and Sub SA-FT1H 5.1
Programming: HR-22 DirecTV HD DVR with AM-21 OTA Add-on and DirecTV SD box for PIP
Gaming: Wii and XBOX 360
HTPC: Dell SX260 (emulators, Netflix, and streaming audio and video from server)
The Blu-ray Mini Marquee NOW AVAILABLE →
  Reply With Quote
Old 09-11-2011, 06:39 AM   #46
Travis Travis is offline
Blu-ray Grand Duke
 
Travis's Avatar
 
Nov 2008
On the sofa
30
1052
295
3
6
Default

At the 1:01 mark, on the trolley, the BD skips and audio and pic cuts in and out for every chapter after that, using 1 month old Marantz UD5005 . First hour plays fine.

Plays fine on fat 80GB PS3, just finished it without issue.
Unwatched Blu-rays: 42
Marantz SR6004; UD5005; CD5003
B&W DM600 S3, LCR60 S3, ASW600 SVS SB12-NSD
Audio-Technica ATH-M50
Toshiba Regza 32C3000G; Sony PS3
Epson PowerLite Home Cinema 5010
Elite Screens M106UWH-E24
  Reply With Quote
Old 10-29-2011, 04:01 AM   #47
Icnbaw Icnbaw is offline
New Member
 
Oct 2011
Default Any news?

I just started to watch Rio and am haveing the same issue as everyone else. Is there any news as to when this could be getting fixed? On a side note I have noticed this problem with one more movie The Green Zone staring Matt Damond. Has any body had an issue with that movie also. I am also watching them on my PS3.
  Reply With Quote
Old 01-07-2012, 02:40 PM   #48
BlueSkyTD BlueSkyTD is offline
New Member
 
Jan 2012
Exclamation Fix in need of testing

Hello guys

I've noticed this problem as well and have looked into it. I was testing using a PS3 Slim system (CECH-2003A) and found the system would 'skip' some scenes in RIO. Although I found that the skipping was not damage to the disk as it was continuing synced with audio. I found this was being caused by what I can only see as the BluRay disk trying to connect to the Fox servers to see if there are any firmware updates available during playback. Someone at Fox has probably made a mistake.

Anyway this is a UNTESTED FIX. On the PS3, if you go to Settings > Network Setting > Set Internet Connection to DISABLE. This will stop the BluRay from trying to search for updates. The 'skipping' will usually happen when the green light indicator on the front of the PS3 is on/flashing. This shows the internet connection is enabled so just disable it.

I've only got confirmation on 2 PS3 Slim systems and would like to know if this fixes it for you guys as well. I believe there should be an option to disable internet connection on Non-PS3 BluRay players but am unsure as I can't test it there. You could always unplug, or turn of the router so there isn't a internet connection I guess.

I really hope this works for you guys as it did when I tested it.
  Reply With Quote
Old 08-24-2013, 06:54 PM   #49
Stev1bp Stev1bp is offline
New Member
 
Aug 2013
Default

I have a Samsung and went into settings and then BD data and cleared the data and it started working fine. I did not return to factory defaults.
  Reply With Quote
Reply
Go Back   Blu-ray Forum > Blu-ray.com > Newbie Discussion


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 09:58 PM.