Best Blu-ray Movie Deals

Best Blu-ray Movie Deals, See All the Deals »

Top deals | Price drops  
 All countries United States United Kingdom Canada Germany France Spain Italy Japan
The Flash: The Complete Third Season (Blu-ray)
$14.99
Supergirl: The Complete Second Season (Blu-ray)
$14.99
The Big Bang Theory: The Complete Tenth Season (Blu-ray)
$14.99
Transformers: The Last Knight 3D (Blu-ray)
$9.99
Gotham: The Complete Third Season (Blu-ray)
$14.99
Supernatural: The Complete Twelfth Season (Blu-ray)
$14.99
The Beguiled (Blu-ray)
$6.49
Monty Python and the Holy Grail (Blu-ray)
$4.99
Planet of the Apes Trilogy (Blu-ray)
$17.99
Star Trek Beyond 3D (Blu-ray)
$9.99
Sherlock: Season Four (Blu-ray)
$14.99
Planet of the Apes Trilogy 4K (Blu-ray)
$31.99
What's your next favorite movie?
Join our movie community to find out


Image from: Life of Pi (2012)

Go Back   Blu-ray Forum > Audio > Subwoofers


Reply
 
Thread Tools Display Modes
Old 01-20-2014, 03:28 AM   #1
cobravenomous cobravenomous is online now
Active Member
 
cobravenomous's Avatar
 
Apr 2009
Ontario, Canada
24
286
Question Paradigm Sub15 Problem

I own a Paradigm Sub15 version five and lately it is cutting out. The blue light at the bottom front intermittently is turning off while the movie is playing. I have the sub set to auto detect the signal and in the past the blue light would always stay on for a number of minutes when the system was shut down. Now the blue light and sub are shutting down during movie or satelite play. Interestingly I can get the sub to shut down at roughly the very same point of the movie when repeated. I contacted Paradigm however they did not reply to my e-mail. Any suggestions would be appreciated. I live in a medium sized city however no longer do we have a paradigm retailer.

Cobra.......
  Reply With Quote
Old 01-20-2014, 04:37 AM   #2
CantonMan CantonMan is offline
Active Member
 
CantonMan's Avatar
 
Aug 2011
12
105
Default

Have you tried turning down the volume on the back of the sub and turning up the level in the receivers settings.
I had problems with my Auto-on function when i bought my Sub and this is what my dealer recommended and ended up fixing the problem all together.
Canton Vento 820.2
Canton Vento 856.2
SVS SB13 Ultra
Yamaha Aventage 810 Reciever, Sony (BDP-370)
Analysis Plus Speaker Wire/ Interconnects
Studer Revox B225 & Parasound ZDAC
Furman Elite 15i
Focal XS Book W/ Calyx DAC
  Reply With Quote
Old 01-20-2014, 04:39 AM   #3
CantonMan CantonMan is offline
Active Member
 
CantonMan's Avatar
 
Aug 2011
12
105
Default

Forgot to mention, many subs turn off if a signal within the crossover constraints is not received for a period of ten minutes or so.
Canton Vento 820.2
Canton Vento 856.2
SVS SB13 Ultra
Yamaha Aventage 810 Reciever, Sony (BDP-370)
Analysis Plus Speaker Wire/ Interconnects
Studer Revox B225 & Parasound ZDAC
Furman Elite 15i
Focal XS Book W/ Calyx DAC
  Reply With Quote
Old 01-20-2014, 03:52 PM   #4
Tom V. Tom V. is offline
Senior Member
 
Jul 2012
Default

Quote:
Originally Posted by CantonMan View Post
Have you tried turning down the volume on the back of the sub and turning up the level in the receivers settings.
I had problems with my Auto-on function when i bought my Sub and this is what my dealer recommended and ended up fixing the problem all together.
+1

Also, if the subwoofer has 2 RCA inputs (left and right) splitting the sub cable and using both inputs can sometimes help too.

Tom V.
  Reply With Quote
Old 01-20-2014, 03:55 PM   #5
Solo man Solo man is offline
Active Member
 
Solo man's Avatar
 
Jan 2013
Toronto, Ontario
72
351
285
1
Default

Quote:
Originally Posted by Tom V. View Post
+1

Also, if the subwoofer has 2 RCA inputs (left and right) splitting the sub cable and using both inputs can sometimes help too.

Tom V.
Good advice, especially if you have a long run, it may help.

To the OP, how long is your cable run?
Love 3D technology and am addicted to it.
My Growing SA-CD collection
http://www.sa-cd.net/library/9866/1
  Reply With Quote
Old 01-20-2014, 04:42 PM   #6
cobravenomous cobravenomous is online now
Active Member
 
cobravenomous's Avatar
 
Apr 2009
Ontario, Canada
24
286
Default

Quote:
Originally Posted by Solo man View Post
Good advice, especially if you have a long run, it may help.

To the OP, how long is your cable run?
Thanks for the suggestions. I'll let you know the results once I try the recommended solutions. The sub cable is a monster sub cable 12' long.
  Reply With Quote
Old 11-30-2014, 05:02 AM   #7
cobravenomous cobravenomous is online now
Active Member
 
cobravenomous's Avatar
 
Apr 2009
Ontario, Canada
24
286
Smile Paradigm Sub 15 Repaired

Quote:
Originally Posted by cobravenomous View Post
Thanks for the suggestions. I'll let you know the results once I try the recommended solutions. The sub cable is a monster sub cable 12' long.
Well after ignoring my problem and not using my home theatre for months I decided to contact Paradigm technical service and they were amazing. Not having a local dealer and not wanting to send a 110+ lb speaker through the mail, Paradigm provided me the steps required to remove the amp from the back of the sub. I did this and sent it to the manufacturer for repair. They had it back to me within ten days completely repaired. Two faulty capacitors........

Now working just like new and a very reasonable repair cost too!

Thanks Paradigm

Cobra
  Reply With Quote
Thanks given by:
Blu-Dog (05-14-2016), Scarriere (05-13-2016)
Old 05-12-2016, 02:36 PM   #8
dmarcink dmarcink is offline
New Member
 
Mar 2013
Geneva IL
170
1
Default Sub-15 Questions

Check your private messages please, RE Sub-15 repair questions.

Thanks
  Reply With Quote
Reply
Go Back   Blu-ray Forum > Audio > Subwoofers


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 04:38 AM.