Best Blu-ray Deals

Best Blu-ray Deals, See All the Deals »
Top deals | Price drops  
 All countries United States United Kingdom Canada Germany France Spain Italy Japan
The Amazing Spider-Man 2 3D (Blu-ray)
$19.99
Scanners (Blu-ray)
$19.99
The Dick Van Dyke Show: The Complete Series (Blu-ray)
$54.99
Kingpin (Blu-ray)
$14.39
Dragon Ball Z: Battle of Gods (Blu-ray)
$17.99
The Devil's Backbone (Blu-ray)
$19.99
Willow (Blu-ray)
$9.96
Planet of the Vampires (Blu-ray)
$19.99
Alien Quadrilogy (Blu-ray)
$22.98
Eyes Without a Face (Blu-ray)
$19.99
Rosemary's Baby (Blu-ray)
$19.99
Mad Men: The Final Season, Part 1 (Blu-ray)
$19.99
Attack on Titan Part 2 (Blu-ray)
$24.95
Rebirth of Mothra I II III (Blu-ray)
$12.99
Videodrome (Blu-ray)
$19.49
Star Trek: The Compendium (Blu-ray)
$24.96
COLLECT WATCH TRACK RATE REVIEW APP
Manage your own movie collection and always keep it with you with our Apps. Price track movies and get price drop notifications instantly. Become a member to take full advantage of all site features.
GET STARTED

Go Back   Blu-ray Forum > Blu-ray > Blu-ray Players and Recorders

Reply
 
Thread Tools Display Modes
Old 02-24-2009, 02:06 AM   #1
JAFlanagan JAFlanagan is offline
New Member
 
Feb 2009
Default Sony S350 won't play certain Blu-Ray discs

This is driving me insane. Does anyone else have any experience with these types of problems?

I bought a Sony S350 from Amazon in December. As far as I knew, it functioned perfectly with BD discs and DVDs. I updated the firmware pretty quickly after I got it. I bought a 3 disc set of Mad Men (great show!) and watched the first disc an a half with no trouble.

Skip ahead a month or so, I'm watching "The Company" on BD from Netflix, and the first disc works fine, but the second won't load at all. It just says, the player cannot read this disc, and stays on the menu. I return it to Netflix, and get a replacement, which works fine.

Last week, I get a copy of "W." and it won't load either. Annoying sure, but tell them the disc doesn't work, and they send me a new one. It won't load either. It was pristine. No scratches, fingerprints or anything. I updated the firmware again, even stuck a 1 GB thumbdrive in the back, just to be sure (even though it wasn't a BD Live disc, but what the heck), and it still doesn't play. No biggie. It's not supposed to be a great movie either way.

The straw that drove me nuts is that tonight, I put the second Mad Men disc back in, and it won't load. Neither will the first disc, or the 3rd, which has never been played. I tried some other discs I have, and they all work fine. I checked the firmware again, reset all the settings on the player and did a power reset. Nothing will make these discs play that played fine before. They aren't damaged in any way.

Checking Sony support, they want me to pack up my player, and ship it to them on my dime to Pennsylvania. I can't return it to Amazon, since it's been over 30 days. So, any thoughts?

Also, thank you, but please don't tell me I should have bought another brand, or get a PS3. That's not really a solution to my problem. Thanks for any helpful advice.

-josh
  Reply With Quote
Old 02-24-2009, 02:29 AM   #2
zombie77 zombie77 is offline
Active Member
 
Jan 2008
Georgia
222
Default

i dunno man i have the same player and a ps3, and i havent had any problems with either player so far.. (knock on wood) and ive played all of madmen s:1 on the stand alone.
  Reply With Quote
Old 02-24-2009, 02:36 AM   #3
Rob J in WNY Rob J in WNY is offline
Blu-ray Guru
 
Rob J in WNY's Avatar
 
Dec 2008
'Western' N.Y. State (MEMBER OF THE "ECPP")
24
348
15
Default

I would assume that your latest firmware update was version .015. I have the Sony BDP-S350 as well, at version .015 (updated from version .010, updated from the original factory version .007), and have not had any problems. I don't have a ton of titles, but I've had no playback problems. If you are running firmware version .015, then you should not be experiencing any disc incompatibilities.

As you suspected, the insertion of the thumb drive does not affect the unit's playback operation.

Sounds like you might have a bad drive in your player. More specifically, it could be a defective laser or pickup. It could be as simple as a dirty laser lens. Not sure if you can use a CD laser type cleaning disc in a BD player, but it may be worth a try.

Lastly, if you can, take your Mad Men discs to a known-good BD player (perhaps a friend's, or even a local audio/video store) to make sure they are fine.

Best of luck to you! The S350 is really a good player!
  Reply With Quote
Old 02-24-2009, 02:40 AM   #4
Avond Avond is offline
Active Member
 
Oct 2008
5
1107
33
Default

The only similar issue I had was with the DVD boxset of Supernatural season 2-it wouldn't recognize the first disc and just registered a ? on the blue setup screen. It would play in my DVD player in another room and the other discs in the set would play on my 350, but it wouldn't recognize that first one. It's the only problem I've ever had and I just wrote it off as a fluke....
  Reply With Quote
Old 02-24-2009, 03:01 AM   #5
Don Blish Don Blish is offline
Member
 
Jun 2006
Los Angeles
Default It could be dust

The following thread describes playability of PS3 discs, but the same could apply to any set of BluRay heads. Upshot: load and reload several times before giving up.

http://forums.support.roxio.com/inde...howtopic=49142
  Reply With Quote
Old 02-24-2009, 03:11 AM   #6
mr.hidef mr.hidef is offline
Power Member
 
mr.hidef's Avatar
 
Sep 2007
Twin Cities
112
557
6
17
Send a message via Yahoo to mr.hidef
Default

332 Blu-ray's and not one single glitch with mine.....
MY HDNA.....IS BLU.....BLU-BLOOD
SONY KDL-52W5100 120Hz / SONY Google TV NSX-40GT
ONKYO TX-SR805 - cooling by Antec
SONY 2 x BDP-S580
MONSTER HDP-2500
KLIPSCH Reference IV series
Dual eD A2-300's
  Reply With Quote
Old 02-24-2009, 04:12 AM   #7
JAFlanagan JAFlanagan is offline
New Member
 
Feb 2009
Default

Quote:
Originally Posted by Rob J in WNY View Post
I would assume that your latest firmware update was version .015. I have the Sony BDP-S350 as well, at version .015 (updated from version .010, updated from the original factory version .007), and have not had any problems. I don't have a ton of titles, but I've had no playback problems. If you are running firmware version .015, then you should not be experiencing any disc incompatibilities.
Yes I'm on .015. And I can't imagine it's the discs. I mean, 1 of them maybe, but all of them? It's just weird.

I think I'm gonna have to send it in. Argh.
  Reply With Quote
Old 02-24-2009, 04:40 AM   #8
krazeyeyez krazeyeyez is offline
Blu-ray Samurai
 
krazeyeyez's Avatar
 
Dec 2007
the guy on the couch
18
155
4
Default

i hope for your wallets sake it is a firmware issue, my s-300 started doing that randomly with some discs not others, progressively became more and more that would not read, even ones i had watched just fine nights earlier! finally no BD playback at all. soon after dvd playback went the same route, i still have the thing lol, i dont even bother to put BDs in it anymore, but dvd's will read if the unit has been off for a day or so lol. ALSO just FYI, i did find that if one of the discs actually read, it played fine, but getting the unit to actually register the disc in the tray, that was a problem ...... good luck
Aggressive MiniHorse

Xbox Tag: KrazeyEyez
  Reply With Quote
Old 02-24-2009, 05:01 AM   #9
JAFlanagan JAFlanagan is offline
New Member
 
Feb 2009
Default

It is under warranty, so hopefully it won't be a complete loss, but I've been down this road, and I can see myself sending it in, where they check it, and find "nothing wrong," and I repeat the process for months until the warranty does run out, and wash my hands of the whole mess.
  Reply With Quote
Old 02-24-2009, 05:25 AM   #10
mr.hidef mr.hidef is offline
Power Member
 
mr.hidef's Avatar
 
Sep 2007
Twin Cities
112
557
6
17
Send a message via Yahoo to mr.hidef
Default

hmmmm..........(open spot for random PS3 fanboy to comment)..........aaaaah silence........is golden.....j/k






JA........I hope all goes well with your player! Keep us posted please.(I had some major issues just like this with an old Samsung BDP-1000)
MY HDNA.....IS BLU.....BLU-BLOOD
SONY KDL-52W5100 120Hz / SONY Google TV NSX-40GT
ONKYO TX-SR805 - cooling by Antec
SONY 2 x BDP-S580
MONSTER HDP-2500
KLIPSCH Reference IV series
Dual eD A2-300's
  Reply With Quote
Old 02-24-2009, 02:10 PM   #11
garytma garytma is offline
Member
 
Aug 2007
Default

I have the S300, and very occasionally see this happen- mostly with Blu discs from Netflix.

I suspect that 2 different issues can occur- at least in my case. One, is simply defective Blu-ray discs. The other, is a dusty, or dirty disc.

Certainly, one can not discount a faulty player- especially if many discs are a problem. But in my case, I started to clean every Blu disc I get from Netflix, and now I rarely have a problem.

I often wonder if, due to the extremely small footprint of the Blu laser, any slight microscopic airborn matter, that might enter the player and get under the laser lens, would momentarily confuse a player causing a momentary glitch, or stick.
  Reply With Quote
Old 02-24-2009, 03:15 PM   #12
JAFlanagan JAFlanagan is offline
New Member
 
Feb 2009
Default

I thought it was the Netflix discs, but I got 2 in a row that didn't work at all. And they were pristine. I cleaned them with my microfiber eyeglasses cloth. In the case of the Mad Men discs, one of them had never been out of the packaging, and it didn't work.
  Reply With Quote
Old 02-24-2009, 03:30 PM   #13
visual0ne visual0ne is offline
Active Member
 
visual0ne's Avatar
 
Jan 2008
United States
12
331
1
Default

I have the same player. It's glitchy sometimes, perhaps just dirty disks? But it's never just locked up on me. (Knock on wood)
LG 55LW5600 Cinema Series 3D TV
Onkyo TX-NR609 Receiver
M&K 750THXMK II LCRs, SURROUND-55s, & 350THX Sub
Panasonic DMP-BDT210 3D BD Player
Nintendo Wii
  Reply With Quote
Old 02-24-2009, 07:02 PM   #14
ryoohki ryoohki is offline
Blu-ray Samurai
 
ryoohki's Avatar
 
May 2007
6
6
8
5
Default

Never had a single glitch with 200+ disc played so far... Not even frozing on anything.
Material : Denon 3808ci, 2xParadigm Monitor 9 v5, 1xCC390, 2xADP390, 2xADP190, Panasonic AE3000 96hz 1080p, 106' screen, Samsung BDP-2550
01/04/08 - A day to remember, the day we won!
My Blu-Ray movies = http://www.invelos.com/dvdcollection.aspx/ryoohki360
  Reply With Quote
Old 02-24-2009, 07:50 PM   #15
Sammy Sammy is offline
Power Member
 
Jan 2009
Right next to Wineville, CA
1
199
1
3
Default

Wait! I thought that Sony BDP's were flawless.
Samsung BD-P2500 (f/w ver 2.7 via USB)
Samsung LN-40A650
Denon AVR-889 7.1 [Retired: 1998 Sony STR-DE925 5.1 dts]
Cherry Polk Audio Monitor 50 Front, JBL Northridge 24II Surrounds & Rears
Cherry Polk Audio CS1 Center Channel
Cherry Polk Audio PSW10 Sub
Patriot Box Office Core HD media player; Technics SL-Q350 O.S. licorice pizza player
Denon ASD-3N media bridge; Sony SLV-M11HF VCR; Logitech Harmony 880
  Reply With Quote
Old 02-24-2009, 08:17 PM   #16
jkwest jkwest is offline
Off-Topic King
 
jkwest's Avatar
 
Jul 2007
Northern California PSN Id: jkwest5
1
20
Default

Quote:
Originally Posted by JAFlanagan View Post
I thought it was the Netflix discs, but I got 2 in a row that didn't work at all. And they were pristine. I cleaned them with my microfiber eyeglasses cloth. In the case of the Mad Men discs, one of them had never been out of the packaging, and it didn't work.
When I used to have Netflix, I had a problem with two rentals before on Blu-ray..with the flapper mailers and the USPS sorting machines, apparently BD's are to resilient...DVD's can bend a little, but, Blu-rays...not so much...sometimes you can see hairline fractures near the spinner hole....

or, you could possibly have a funky player...is it under warranty?
"Climb the mountains and get their good tidings. Nature's peace will flow into you as sunshine flows into trees. The winds will blow their own freshness into you, and the storms their energy, while cares will drop away from you like the leaves of Autumn."
John Muir
  Reply With Quote
Reply
Go Back   Blu-ray Forum > Blu-ray > Blu-ray Players and Recorders

Similar Threads
thread Forum Thread Starter Replies Last Post
Why won't my Blu-ray discs play in surround sound? Home Theater General Discussion inlayterms 25 12-23-2012 02:39 PM
Will a Sony BDP-s350 play DVD Audio or SACD? Blu-ray Players and Recorders timbosheen 3 10-03-2009 06:05 PM
Can't play Blu-ray discs - Fixed :D Blu-ray PCs, Laptops, Drives, Media and Software hellboy188 12 06-12-2009 10:55 AM
UK blu-ray and HD-DVD discs on Play.com Blu-ray Movies - North America partridge 10 02-02-2007 05:18 AM


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 08:35 AM.