Best Blu-ray Movie Deals


Best Blu-ray Movie Deals, See All the Deals »

Top deals | New deals  
 All countries United States United Kingdom Canada Germany France Spain Italy Australia Japan
Ringu Collection (Blu-ray)
$49.99
18 hrs ago
Doctor Sleep 4K (Blu-ray)
$29.99
5 hrs ago
Godzilla: The Showa-Era Films, 1954-1975 (Blu-ray)
$112.49
 
Farscape: The Complete Series (Blu-ray)
$59.99
 
The Complete Sartana (Blu-ray)
$49.99
1 hr ago
Ad Astra 4K (Blu-ray)
$24.99
 
The Sopranos: The Complete Series (Blu-ray)
$54.99
 
Teen Titans: The Complete Series (Blu-ray)
$37.59
 
Mission: Impossible - 6-Movie Collection 4K (Blu-ray)
$50.39
 
The Big Bang Theory: The Complete Series (Blu-ray)
$179.95
7 hrs ago
Beverly Hills Cop Trilogy (Blu-ray)
$19.99
 
Once Upon a Time in Hollywood 4K (Blu-ray)
$56.99
 
What's your next favorite movie?
Join our movie community to find out


Image from: Life of Pi (2012)

Go Back   Blu-ray Forum > Audio > Subwoofers


Reply
 
Thread Tools Display Modes
Old 05-08-2018, 04:09 AM   #1
Xenomorph Xenomorph is offline
Active Member
 
Xenomorph's Avatar
 
Feb 2009
3
1
Default Help with Subs and Turntable

Hey all,
Sub(s) acting strange when I crank up the music using my turntable. Everything's fine normally but I wanted to be able to hear the music in the next room. As soon as I turned it up the sub just played a solid note. I tried unplugging one of the subs and it still does it.
Turntable hooked up to a Schiit Mani preamp, then connected to an Onkyo TX-RZ800 but it still does it when I swap out the preamp.
I have the turntable connected to CD in on the Onkyo as the receiver's phono stage is pretty terrible.
There's no noise between tracks or when I lift the needle so it's not a hum or anything from the turntable.

Here's a quick vid of the sub..kind of hard to hear but it's a steady deep note and the driver keeps vibrating like that.


Last edited by Xenomorph; 05-08-2018 at 04:16 AM.
  Reply With Quote
Old 05-08-2018, 03:18 PM   #2
Xenomorph Xenomorph is offline
Active Member
 
Xenomorph's Avatar
 
Feb 2009
3
1
Default

Problem solved please delete post.
Believe it or not the dust cover on the turntable being left open was causing a weird sort of feedback. Closing it fixed the problem. :O
  Reply With Quote
Reply
Go Back   Blu-ray Forum > Audio > Subwoofers


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 07:58 AM.