Best Blu-ray Movie Deals


Best Blu-ray Movie Deals, See All the Deals »
Top deals | New deals  
 All countries United States United Kingdom Canada Germany France Spain Italy Australia Netherlands Japan Mexico
The Gentlemen 4K (Blu-ray)
$19.99
 
Flesh Eating Mothers (Blu-ray)
$13.99
 
1917 4K (Blu-ray)
$19.99
 
The Incredible Hulk (Blu-ray)
$5.99
14 hrs ago
Zombieland: Double Tap 4K (Blu-ray)
$14.99
 
JoJo's Bizarre Adventure: Set 5 - Diamond is Unbreakable Part 2 (Blu-ray)
$39.99
 
Unforgiven 4K (Blu-ray)
$14.99
1 hr ago
Watchmen: An HBO Limited Series (Blu-ray)
$29.99
 
Once Upon a Time in Hollywood (Blu-ray)
$9.99
 
Spider-Man: Far from Home 4K (Blu-ray)
$14.99
 
Saving Private Ryan 4K (Blu-ray)
$14.99
19 hrs ago
Bloodshot (Blu-ray)
$17.99
 
What's your next favorite movie?
Join our movie community to find out


Image from: Life of Pi (2012)

Go Back   Blu-ray Forum > Blu-ray.com > Feedback Forum


Reply
 
Thread Tools Display Modes
Old 04-25-2020, 02:44 AM   #1
kedavis kedavis is offline
Active Member
 
kedavis's Avatar
 
Sep 2011
San Diego
97
1059
62
8
9
3
1
Default wrong country

For the last 2 days, when I open this site on my PC with the latest Firefox browser, I've been seeing UK & Australia(?) flags next to the latest reviews and new preorders.
There's a US flag & says "United States" on the top right above "logged in as."
I've logged out and back in, clicked the globe and then the US flag below "top deals," but nothing seems to help. Yesterday after a few minutes of navigation around the site, it went back to normal, but today the UK flags are back. After repeating all the steps from yesterday, the foreign flags are gone from preorders, but remain in latest reviews.
How do I fix it?
home screen.jpg

Last edited by kedavis; 04-25-2020 at 02:45 AM. Reason: typo
  Reply With Quote
Old 04-25-2020, 08:38 AM   #2
Lynos Lynos is offline
Member
 
May 2017
3
86
72
Default

Yup, I'm having the same thing (on Chrome).

Seems like a bug.
  Reply With Quote
Thanks given by:
kedavis (04-25-2020)
Old 04-25-2020, 02:05 PM   #3
smax-3 smax-3 is offline
Active Member
 
smax-3's Avatar
 
Jun 2013
126
852
6
116
129
127
1
3
Default

I had a thread for the same thing but then it disappeared after the issue was fixed. For what it's worth, I'm not having the issue anymore.
  Reply With Quote
Thanks given by:
kedavis (04-25-2020)
Old 04-25-2020, 02:53 PM   #4
boxpilot boxpilot is offline
Junior Member
 
Dec 2012
Default

Just had the same issue. Had to go into my preferences and deselect all countries except the US.
  Reply With Quote
Thanks given by:
kedavis (04-25-2020)
Old 04-25-2020, 09:08 PM   #5
kedavis kedavis is offline
Active Member
 
kedavis's Avatar
 
Sep 2011
San Diego
97
1059
62
8
9
3
1
Default

Quote:
Originally Posted by boxpilot View Post
Just had the same issue. Had to go into my preferences and deselect all countries except the US.
I looked in my preferences. Only the US was selected for Blu-ray Movies & News. Weirdly, in Reviews, Israel, Romania, & US were selected. I unchecked the 1st 2.
Saving preferences, logging out, and returning to the home page, I still find that more than half the listed reviews are from the UK & Australia.
Sigh. I'll just have to ignore the reviews until the glitch is corrected.
  Reply With Quote
Thanks given by:
Schrute Farms (04-27-2020)
Old 04-26-2020, 09:13 PM   #6
Nick Michalak Nick Michalak is offline
Member
 
Nick Michalak's Avatar
 
Sep 2015
Glendale Heights, IL
5
344
86
1
Default

Same issue here. I updated all my preferences for my feed, but I'm still getting UK & Australian reviews posting there.
  Reply With Quote
Old 04-27-2020, 04:47 PM   #7
Schrute Farms Schrute Farms is offline
Special Member
 
Schrute Farms's Avatar
 
Dec 2007
Appleton, Wisconsin
33
387
19
31
Default

Same annoying issue here. Logged in and out and checked site preferences. It’s unfortunate that none of the admins have commented on this...
  Reply With Quote
Old 05-06-2020, 04:49 AM   #8
kedavis kedavis is offline
Active Member
 
kedavis's Avatar
 
Sep 2011
San Diego
97
1059
62
8
9
3
1
Default

Tonight, for the 1st time in a week, all the reviews on the site home page are from the US. Hooray! It was almost as exciting as finding all-purpose flour & red cherries at the store today.
Thanks for whomever fixed it.
Update: I spoke too soon. This afternoon, Wednesday 5/6/2020, the foreign reviews are back

Last edited by kedavis; 05-06-2020 at 08:45 PM. Reason: update
  Reply With Quote
Old 05-08-2020, 02:03 AM   #9
kedavis kedavis is offline
Active Member
 
kedavis's Avatar
 
Sep 2011
San Diego
97
1059
62
8
9
3
1
Default

Now, not only am I getting UK & Australian reviews on my home page, I'm getting UK releases in my Top News Feed.
What's the point of personalized settings if they're just going to be ignored?
Two days ago things were briefly back to normal. Sadly it didn't last.
  Reply With Quote
Thanks given by:
Nick Michalak (05-20-2020)
Old 05-20-2020, 03:44 AM   #10
Nick Michalak Nick Michalak is offline
Member
 
Nick Michalak's Avatar
 
Sep 2015
Glendale Heights, IL
5
344
86
1
Default

This problem persists. No idea why this hasn't been fixed or addressed yet by site staff.
  Reply With Quote
Reply
Go Back   Blu-ray Forum > Blu-ray.com > Feedback Forum


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 06:35 PM.