Best Blu-ray Movie Deals


Best Blu-ray Movie Deals, See All the Deals »
Top deals | New deals  
 All countries United States United Kingdom Canada Germany France Spain Italy Australia Netherlands Japan Mexico
Major Dundee (Blu-ray)
$59.95
4 hrs ago
Weird Wisconsin: The Bill Rebane Collection (Blu-ray)
$72.99
1 day ago
Laurel & Hardy - The Definitive Restorations (Blu-ray)
$42.99
18 hrs ago
Little Shop of Horrors (Blu-ray)
$9.99
13 hrs ago
Indiana Jones: 4-Movie Collection 4K (Blu-ray)
$79.99
 
Cool as Ice (Blu-ray)
$17.99
8 hrs ago
Saw 4K (Blu-ray)
$17.99
1 day ago
Donnie Darko 4K (Blu-ray)
$32.99
 
The Maltese Falcon (Blu-ray)
$9.99
17 hrs ago
Thundarr the Barbarian: The Complete Series (Blu-ray)
$24.99
1 hr ago
Masculin Féminin (Blu-ray)
$27.99
2 hrs ago
The Eurocrypt of Christopher Lee Collection (Blu-ray)
$109.99
 
What's your next favorite movie?
Join our movie community to find out


Image from: Life of Pi (2012)
Old 02-05-2021, 05:11 AM   #1
Riddler The Slag Riddler The Slag is offline
Blu-ray Samurai
 
Riddler The Slag's Avatar
 
Jan 2010
Tulsa, OK (formally S. Wales)
53
141
717
68
Default Handshake

I bought the BenQ HT3550. Replaced the old Epson 1080. I had upgraded the receiver and the 4K UHD player.

Plug it all in today and their is no signal. Now, if I turn the HDMI from Enhanced to Standard....I get picture. If I go to the 4K player and try to play a 4K resolution, the projector loses signal.

SO

My theory is that the HDMI cable is the culprit. I welcome any thoughts.
  Reply With Quote
Reply
Go Back   Blu-ray Forum > Displays > Projectors


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 01:41 AM.