Best Blu-ray Movie Deals


Best Blu-ray Movie Deals, See All the Deals »
Top deals | New deals  
 All countries United States United Kingdom Canada Germany France Spain Italy Australia Netherlands Japan Mexico
Les MisÚrables 4K (Blu-ray)
$17.96
22 hrs ago
Film Noir: The Dark Side of Cinema XIV (Blu-ray)
$24.99
2 hrs ago
The Night of the Hunter 4K (Blu-ray)
$19.99
1 day ago
Sisu 4K (Blu-ray)
$26.36
 
The Experts (Blu-ray)
$12.49
5 hrs ago
The Package (Blu-ray)
$12.49
22 hrs ago
The Longest Yard 4K (Blu-ray)
$19.99
1 day ago
Tropic Thunder 4K (Blu-ray)
$19.99
2 hrs ago
Serpico 4K (Blu-ray)
$19.99
1 day ago
Hustle (Blu-ray)
$14.99
15 hrs ago
Needful Things 4K (Blu-ray)
$24.49
 
12 Angry Men 4K (Blu-ray)
$19.99
6 hrs ago
What's your next favorite movie?
Join our movie community to find out


Image from: Life of Pi (2012)

Go Back   Blu-ray Forum > Audio > Subwoofers

Reply
 
Thread Tools Display Modes
Old 08-30-2013, 06:31 PM   #1021
soundwave628 soundwave628 is offline
Senior Member
 
Jul 2011
Default

I know these have fallen out of favor lately but I just recalibrated and have been enjoying my Epik Legend. I've checked out their site lately and thought they were out of business but I just noticed they're coming out with a new 18" sub!?
  Reply With Quote
Old 08-30-2013, 07:20 PM   #1022
dolsey01 dolsey01 is offline
Active Member
 
dolsey01's Avatar
 
Mar 2011
Boston, MA
Default

Yep lots of Epik hate lately but it sounds like they are starting to come back to life. Someone over on AVS was able to get a Empire amp replaced in the last week or two so hopefully they will get their act together. I also have a Legend and after the amp failed and was replaced under warranty last year, it's been working and sounding great. I actually have it listed along with a Polk PSW1000 on Craigslist and have not had one single bite. I have been downsizing my home theater to fund my 2ch system and decided I didn't need two subs anymore and would keep which ever sold but it seems there is no interest in either and I priced them to sell.

I think if Epik can deliver on the 18" sub and actually answer the phone and emails, they might bounce back from all the negative vibe that's been going on.
  Reply With Quote
Old 08-30-2013, 11:09 PM   #1023
red_5ive red_5ive is offline
Blu-ray Knight
 
red_5ive's Avatar
 
Aug 2007
Temecula, CA
18
261
881
4
2
1
Default

I have a Legend in my 2nd setup, small room about 10x12. It's a little over 3 years old and still on the original amp. It hasn't been sounding great lately so I was having thoughts of getting something else from HSU. But, I also recalibrated and set it +3db hot, and I'm back in business. That mid sub bass I was missing is back. I'm happy again.
  Reply With Quote
Old 09-01-2013, 06:20 PM   #1024
soundwave628 soundwave628 is offline
Senior Member
 
Jul 2011
Default

I'm still enjoying my legend from 2 years ago especially paired with a similar sub I got used on Craigslist. I'm sure I'm missing some of the really low stuff but I get some good slam and when I put music on it sounds really tight.
  Reply With Quote
Old 09-02-2013, 08:26 PM   #1025
theJman theJman is offline
Senior Member
 
theJman's Avatar
 
Sep 2011
New Joisey
Default

Quote:
Originally Posted by soundwave628 View Post
I know these have fallen out of favor lately but I just recalibrated and have been enjoying my Epik Legend. I've checked out their site lately and thought they were out of business but I just noticed they're coming out with a new 18" sub!?
And you should continue to enjoy it, for as long as you feasibly can. For all intents and purposes though, Epik is out of business. I can't imagine any plausible scenario where they could pull a phoenix and resurrect themselves after what's transpired this past year or so. Chad may actually be planning to release new subwoofers, but it's not likely he'll be able to use the Epik name any longer. It's been stained badly at this point, and has become the punchline to a 100 jokes. It's a shame too, because he had a good thing going for a while there; a lot of people - the ones who didn't have amp issues at least - really liked their subs.
  Reply With Quote
Old 09-02-2013, 11:02 PM   #1026
soundwave628 soundwave628 is offline
Senior Member
 
Jul 2011
Default

It's a shame too because now some of the best subs seem to going for multiple drivers in sealed enclosures. Seems like epik was ahead of the game.
  Reply With Quote
Old 09-03-2013, 02:45 AM   #1027
chadwick537 chadwick537 is offline
Member
 
chadwick537's Avatar
 
Jan 2013
Wausau, Wisconsin
40
Default Epik

Anyone looking to get rid of one (preferably two) Empires or Legends at a reasonable price? I live in Wisconsin. Send me a PM if interested.
  Reply With Quote
Old 01-13-2014, 02:50 AM   #1028
RocShemp RocShemp is offline
Blu-ray Samurai
 
Jul 2009
2
Default

Just got an e-mail from Epik that they're going out of business. The e-mail contained the following link regarding a Going Out Of Business Sale. I truly feel sorry for Chad.
  Reply With Quote
Old 01-13-2014, 02:12 PM   #1029
JJ JJ is offline
Blu-ray Count
 
JJ's Avatar
 
Jul 2007
Miami, FL
98
452
1118
32
5
18
190
Send a message via AIM to JJ Send a message via Yahoo to JJ
Default

Quote:
Originally Posted by RocShemp View Post
Just got an e-mail from Epik that they're going out of business. The e-mail contained the following link regarding a Going Out Of Business Sale. I truly feel sorry for Chad.
Same here, and noticed their Facebook post. Bought a shirt. If they had any Epik amps left, I would've scooped one up, but alas - none.
  Reply With Quote
Old 01-13-2014, 05:25 PM   #1030
theJman theJman is offline
Senior Member
 
theJman's Avatar
 
Sep 2011
New Joisey
Default

Quote:
Originally Posted by RocShemp View Post
Just got an e-mail from Epik that they're going out of business. The e-mail contained the following link regarding a Going Out Of Business Sale. I truly feel sorry for Chad.
I feel more sorry for all the people he hosed on their warranties, especially in light of the fact that it appears he's been sitting on parts for quite some time. That's pretty low.
  Reply With Quote
Old 01-13-2014, 06:46 PM   #1031
dolsey01 dolsey01 is offline
Active Member
 
dolsey01's Avatar
 
Mar 2011
Boston, MA
Default

Helps justify my decision of why I sold my Legend. It's really too bad. Another ID sub company bites the dust.
  Reply With Quote
Old 01-13-2014, 07:24 PM   #1032
red_5ive red_5ive is offline
Blu-ray Knight
 
red_5ive's Avatar
 
Aug 2007
Temecula, CA
18
261
881
4
2
1
Default

I got the email as well. Truly sad news, even if the writing was on the wall. I feel for Chad. Great guy. I talked with him several times before and after purchasing my Legend in early 2011. It's still running strong, and if the amp ever does go out, a simple mod to a pro amp and I'm good. I've learned to dislike plate amps anyway, and I'm using external amplification now for one of my other subs. If I had the cash (still recovering from Christmas), I wouldn't hesitate to take advantage of another Legend or 2, or even an Empire, at the blowout prices.
  Reply With Quote
Old 01-18-2014, 05:56 AM   #1033
RocShemp RocShemp is offline
Blu-ray Samurai
 
Jul 2009
2
Default

A guy over at AVS posted how he just repaired his Empire and I thought it'd be of interest to those here, should they ever need it:

Quote:
Originally Posted by bek1973
I fixed my Empire!!! - see below or read my story - I too have been trying to contact Epik via email and phone for the last month due to what I thought was an amp issue. I wouldn't attempt to work on it either worried about voiding my faux warranty.
Anyway - after I got the disturbing email from Chad about "Business is closing - oh btw buy all this old stock while I don't honor my warranty" I was furious.
I thought about buying the replacement amp and then contesting on the credit card - then Chad would have to talk to someone.
Anyway - I decided I wasn't going to gamble on Chad or the amp - I was going to take my Empire apart as soon as I got home.

Description of problem - I would turn my Empire on - light would come on Green and as soon as a low signal came on sub would make slight low crackle noise on one side and green light would fade out and it would not power on for 10-15 min. It would power on later but would repeat problem.

I first removed amp - upon removal I looked it over for any burns or melts and it looked fine - the only thing that was concerning was the very small heat sink. The enclosure was jammed with polyfill - I mean jammed!


I then removed the speaker on the side that made the crackle - I immediately noticed the two leads going to woofer had fused together! I instinctively touched them and gently rolled them between my fingers breaking the bond before I took pic - sorry. Anyway - it looks like the leads may have been angled at each other when soldered to terminal causing them to touch during excursion. Anyway - here is pic right after - you can see how they were shaped as if they had mated.


With this being the secondary sub in the series I turned the amp on and it worked driving the one woofer. I then reinstalled secondary sub and it seems to be working fine. I may re-solder that woofer at the terminal and reverse the angle of the leads but I reinstalled both subs in a way where I can view the leads by removing the amp. This amp must have some decent protection?

I hope this helps some -
Kiser
  Reply With Quote
Old 01-27-2014, 03:52 PM   #1034
RocShemp RocShemp is offline
Blu-ray Samurai
 
Jul 2009
2
Default

Another user at AVS just posted his experience fixing his Epik Legend and then later getting the amp fixed:

Quote:
Originally Posted by Coopaw
Legend failure / repair update:

Like many, my Legend failed. right before the holidays. I spent very little effort trying to contact Chad even though mine was in warranty. Why waste time and energy, I decided to move on. So my approach was to pull the amp and have a friend look at it. His comment was that it appeared fairly well built and he could see no obvious mode of failure but we quickly isolated the problem to the power output board by unplugging the control board and seeing that the fuse no longer blew.

He was going away for the holidays so I knew it would be a while before he could get back to it and then no guarantee he could fix is so I did some measuring and being impatient decided to order a Bash 500 from Parts express. I modified the cabinet to take the larger plate amp and was up and running in a matter of hours after the amp arrived. I enlarged the hole, routed a lip for the amp to sit flush but you wouldn't have to do that. I repurposed the material from the "box" inside so the poly fill would not work it's way into the amp area and smother the new amp causing heat issues.
see pics:





Works just fine and is always cool to the touch.

Now that my friend is back he diagnosed the problem with the Epik amp, in my case to one bad output transistor see pic. (I'm pointing to it with the screw driver.) There are two but only the one under the capacitor was bad.



The part is an obsolete Toshiba FET so he found a replacement for about $3 and bought a tube of heat sink grease and replaced the part and put new grease under all the devices as well as the heat sink where it joins the back plate. This job requires removing the heat sink from the plate, the clamps that hold the FET's to the heat sinks and unsoldering the FET and replacing everything. ( I will ask my friend what the replacement part number was for anyone interested.)

So it's all back together and working fine. I have it for sale if anyone is interested PM me. I'll guarantee it for 30day but after that you are on your own. Since I enlarged the hole in the cabinet, I can't put it back in mine.

We also ran some tests on the Epik amp to figure out if there was a boost programmed into it or not. There is a 6 to 9db boost at 22 hz. So anyone looking to buy a replacement amp and modify the cabinet can keep that in mind. The Bash I bought allows me to change two resistors and mimic this curve so we did that this afternoon. Parts express also sells a 300 watt plate amp with a 6db boost at 25hz which should work well also.

Repairing the amp is not difficult for anyone familiar with soldering and working on electronics but your amp might have a different mode of failure.

I'll be glad to try to answer any question. Hope this is helpful to those out there with dead subs.
  Reply With Quote
Old 07-17-2015, 01:22 PM   #1035
soundwave628 soundwave628 is offline
Senior Member
 
Jul 2011
Default

So I finally finished my attic and go to set everything up and my Epik Legend subwoofer doesn't turn on!? It has been sitting unplugged for about 8 months, what gives? I've read there were amp issues and they keep blowing fuses (which I didn't have a chance to check) but would that happen while it's just sitting unused?

I really didn't have money planned to purchase a new sub, I do have an older one I can use but damn. Power Sound audio seems to be getting more and more expensive too
  Reply With Quote
Old 09-19-2015, 08:56 AM   #1036
Dreamliner330 Dreamliner330 is offline
Blu-ray Ninja
 
Dreamliner330's Avatar
 
Jan 2012
1
491
1112
1
405
Default

Quote:
Originally Posted by soundwave628 View Post
So I finally finished my attic and go to set everything up and my Epik Legend subwoofer doesn't turn on!? It has been sitting unplugged for about 8 months, what gives? I've read there were amp issues and they keep blowing fuses (which I didn't have a chance to check) but would that happen while it's just sitting unused?

I really didn't have money planned to purchase a new sub, I do have an older one I can use but damn. Power Sound audio seems to be getting more and more expensive too
If you just have the one sub, get a Behringer iNUKE NU3000 or NU3000DSP. I bought a NU6000DSP (from Sweetwater) for my two Empires. I couldn't be happier. The amps are seriously good stuff and way cheaper than buying another sub. Epik made good subs, their amps...not so much.
  Reply With Quote
Reply
Go Back   Blu-ray Forum > Audio > Subwoofers

Similar Threads
thread Forum Thread Starter Replies Last Post
The Official SVS Subwoofer Owners Thread Subwoofers Jwilly019 18588 Yesterday 05:45 AM
The Official Paradigm Subwoofer Owners Thread Subwoofers Big Daddy 297 11-30-2022 03:20 AM
The Official Klipsch Subwoofer Owners Thread Subwoofers Big Daddy 228 05-18-2022 01:37 AM
The Official Axiom Subwoofer Owners Thread Subwoofers Big Daddy 17 07-28-2020 12:34 PM
The Official Sunfire Subwoofer Owners Thread Subwoofers Big Daddy 51 07-04-2018 06:02 PM


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 09:13 AM.