Best 3D Blu-ray Deals


Best Blu-ray Movie Deals, See All the Deals »
Top deals | New deals  
 All countries United States United Kingdom Canada Germany France Spain Italy Australia Japan
Universal Classic Monsters: The Essential Collection (Blu-ray)
$29.99
 
Dredd 4K (Blu-ray)
$9.99
 
Avatar 3D (Blu-ray)
$14.99
 
Spider-Man: Homecoming 3D (Blu-ray)
$12.80
 
Shazam! 3D (Blu-ray)
$27.47
6 hrs ago
Ghostbusters 4K + 3D (Blu-ray)
$14.96
 
Passengers 4K + 3D (Blu-ray)
$14.96
 
The Polar Express 3D (Blu-ray)
$13.69
 
Abominable 3D (Blu-ray)
$36.00
 
The LEGO Movie 2: The Second Part 3D (Blu-ray)
$19.99
 
X-Men: Days of Future Past 3D (Blu-ray)
$6.99
 
Fantastic Beasts: The Crimes of Grindelwald 3D (Blu-ray)
$19.99
 
What's your next favorite movie?
Join our movie community to find out


Image from: Life of Pi (2012)

Go Back   Blu-ray Forum > 3D > 3D Hardware and Technology > 3D Players


Reply
 
Thread Tools Display Modes
Old 06-06-2011, 01:14 AM   #1
Blu-man08 Blu-man08 is offline
Senior Member
 
Blu-man08's Avatar
 
May 2008
Michigan
84
405
86
Default Sony BDP S470 Playback Issue

Hey all. I'm having an issue with this blu-ray player not displaying the first 2 - 3 seconds of any blu-ray disc. This issue applies to initial playback of each disc's section/title (Opening Studio Logos, FBI Warnings, forced trailers, main menu, the beginning of the feature film). It's an annoyance and I was wondering if anyone else had dealt with this issue and what the solution might be.
  Reply With Quote
Old 06-16-2011, 12:55 PM   #2
desiguy2447 desiguy2447 is offline
Member
 
Sep 2009
Default

I have the same issue on, and off.. I posted it to the Sony Forum on the Sony website. In my case the screen goes blank for 2 to 3 seconds once the BD starts from the main menu of the disc. (not all time).
  Reply With Quote
Old 06-17-2011, 03:49 PM   #3
RSuarez RSuarez is offline
Power Member
 
RSuarez's Avatar
 
Jan 2009
MX / TX
22
595
Send a message via MSN to RSuarez
Default

Quote:
Originally Posted by desiguy2447 View Post
I have the same issue on, and off.. I posted it to the Sony Forum on the Sony website. In my case the screen goes blank for 2 to 3 seconds once the BD starts from the main menu of the disc. (not all time).
I am having the exact same issue but it is quite random, the weird thing is that I have not installed any updates or the like, it just started happening...

  Reply With Quote
Old 02-01-2012, 05:25 PM   #4
3Dfan 3Dfan is offline
Active Member
 
Oct 2011
Default

[QUOTE=Blu-man08;4810783]Hey all. I'm having an issue with this blu-ray player not displaying the first 2 - 3 seconds of any blu-ray disc. This issue applies to initial playback of each disc's section/title (Opening Studio Logos same on my bdp s480
  Reply With Quote
Old 02-17-2016, 05:39 PM   #5
syndicate syndicate is offline
Active Member
 
Jun 2011
220
377
Default

I don't have the problems like all of you have. But my Sony S470 will not play two of the Fox Blu-rays from last year. After the Fox Home Entertainment logo, it would say I need to update the player in order to play it. The two Fox Blu-rays are Taken 3 and Kingsman: Secret Service. I don't know about other Fox Blu-rays released last year would it have the same messages. Both of them brought at Best Buy

My Uncle who has the same Sony Blu-ray player, but with a different original factory installed firmware, played those two Fox Blu-rays with NO PROBLEMS. Both of are players were brought from the same Sony outlet store at an outlet mall. But at different time in 2010, but not too far off. The store has close like some time in 2012 or 2013. My Uncle NEVER updated his Sony S470 player's firmware and I NEVER updated mine either since getting it The only reason I know the firmware different, because I check. Even my Uncle's roommate's Sony Blu-ray player which is a older model, the Sony BX1 and itload Blu-rays slower would also play it. Also it is the original factory installed firmware too for that player. He NEVER updated it either.

I have tried and play Blu-rays from other studios that was also released last year, like Tomorrowland, American Sniper, Mission Impossible: Rogue Nation, Terminator Genisys, Cinderella, Aladdin, Inside Out, 101 Dalmatians and John Wick and they all work and play without needing any updates.

So far BD released this year that works on the Sony S470without any updates needed, are Bridge of Spies and Spectre(Fox helping MGM, it the Target Exclusive).

But all Fox Blu-rays released before 2015 all still work and it Does NOT out of a sudden get the same message and not play anymore till the Sony S470 is updated. So no problems with BDs like The Grand Budapest Hotel, A Good Day To Die Hard, all 23 of the James Bond movies(Fox helping MGM) that was released, The King and I, The Magnificent Seven(Fox helping MGM), X-Men: Days of Future Past, Broken Arrow, The A-Team(Target Exclusive) and so on.

So any ideas anyone as to why is that, would be great.

Last edited by syndicate; 02-18-2016 at 09:58 AM.
  Reply With Quote
Reply
Go Back   Blu-ray Forum > 3D > 3D Hardware and Technology > 3D Players


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 01:44 PM.