Best 4K Blu-ray Deals

Best Blu-ray Movie Deals, See All the Deals »
Top deals | New deals  
 All countries United States United Kingdom Canada Germany France Spain Italy Australia Japan
Godzilla: King of the Monsters 4K (Blu-ray)
$29.99
 
Dark Phoenix 4K (Blu-ray)
$29.99
 
Hellboy 4K (Blu-ray)
$24.99
 
Alita: Battle Angel 4K + 3D (Blu-ray)
$29.96
 
Terminator 2: Judgment Day 4K (Blu-ray)
$7.50
 
Gremlins 4K (Blu-ray)
$25.99
 
The Shining 4K (Blu-ray)
$24.99
 
Kingsman: The Secret Service 4K (Blu-ray)
$14.99
3 hrs ago
Batman vs. Teenage Mutant Ninja Turtles 4K (Blu-ray)
$19.99
 
Logan 4K (Blu-ray)
$14.99
17 hrs ago
Pan's Labyrinth 4K (Blu-ray)
$24.99
 
Captain Marvel 4K (Blu-ray)
$29.96
 
What's your next favorite movie?
Join our movie community to find out


Image from: Life of Pi (2012)

Go Back   Blu-ray Forum > Ultra HD Blu-ray and 4K > Ultra HD Blu-ray and 4K Hardware and Technology


Reply
 
Thread Tools Display Modes
Old 04-20-2019, 06:24 AM   #1
adamjankowski adamjankowski is offline
Active Member
 
adamjankowski's Avatar
 
Oct 2017
25
261
46
Default Need Help With Audio For Panasonic UB820 Blu-ray Player

I am in desperate need of help.

I just got the UB820 player upon recommendation that it would greatly help the picture quality of UHD/4k Blu-rays since I kept encountering drastically dark 4k Blu-rays compared to regular Blu-rays. This seems to have helped correct that issue, for the most part.

However, for the life of me, I CANNOT get the audio to work on my player in conjunction with my receiver. The receiver is an older Yamaha RX-V630 and worked great with my Sony X800 player. It connected to the player via a single coxial audio cable. However this UB820 model only accepts HDMI or optical cord. I picked up an optical cord, but I am not sure about the correct settings for this, as there are many audio settings in the menu of the player. I have played around with the menu options, but I have to be missing something as there has to be a way for this work. The instruction booklet doesn't even mention all the audio options shown in the actual player menu, either.

Can anyone please help me? I am happy with the picture quality, but am clueless how to to get the audio to work and come through my amplifier/speakers.

I posted this in another thread as well. I am lost. Any help would be greatly appreciated.
  Reply With Quote
Old 04-20-2019, 06:52 AM   #2
DJR662 DJR662 is offline
Blu-ray Ninja
 
DJR662's Avatar
 
Feb 2009
27
Default

In the Digital Audio Output menu, are Dolby and DTS set to bitstream with Secondary audio set to On?

Also make sure Audio Output is set to off for HDMI.

Last edited by DJR662; 04-20-2019 at 06:57 AM.
  Reply With Quote
Old 04-20-2019, 06:57 AM   #3
adamjankowski adamjankowski is offline
Active Member
 
adamjankowski's Avatar
 
Oct 2017
25
261
46
Default

Quote:
Originally Posted by DJR662 View Post
In the Digital Audio Output menu, are Dolby and DTS set to bitstream with Secondary audio set to On?

Also make sure Audio Output is set to off for HDMI.
Yes.
  Reply With Quote
Old 04-20-2019, 07:00 AM   #4
DJR662 DJR662 is offline
Blu-ray Ninja
 
DJR662's Avatar
 
Feb 2009
27
Default

Quote:
Originally Posted by adamjankowski View Post
Yes.
HDMI --> Advanced Settings --> Audio Output.

Has that been set to off?
  Reply With Quote
Old 04-20-2019, 07:02 AM   #5
adamjankowski adamjankowski is offline
Active Member
 
adamjankowski's Avatar
 
Oct 2017
25
261
46
Default

Quote:
Originally Posted by DJR662 View Post
HDMI --> Advanced Settings --> Audio Output.

Has that been set to off?
Yes.
  Reply With Quote
Old 04-20-2019, 07:07 AM   #6
DJR662 DJR662 is offline
Blu-ray Ninja
 
DJR662's Avatar
 
Feb 2009
27
Default

Quote:
Originally Posted by adamjankowski View Post
Yes.
Hmm...

Sound --> Settings for High Clarity Sound --> Audio Output (of video playback).

Perhaps changing that setting to "OPTICAL Only" will work (if you haven't tried that already)?
  Reply With Quote
Old 04-20-2019, 07:09 AM   #7
adamjankowski adamjankowski is offline
Active Member
 
adamjankowski's Avatar
 
Oct 2017
25
261
46
Default

Quote:
Originally Posted by DJR662 View Post
Hmm...

Sound --> Settings for High Clarity Sound --> Audio Output (of video playback).

Perhaps changing that setting to "OPTICAL Only" will work (if you haven't tried that already)?
I did that for both video playback and audio playback.
  Reply With Quote
Old 04-20-2019, 07:13 AM   #8
adamjankowski adamjankowski is offline
Active Member
 
adamjankowski's Avatar
 
Oct 2017
25
261
46
Default

Does the HDMI(video) Output Mode and HDMI (audio) Output mode need to be set to a particular mode? There are two options for both - Auto and Video + Audio.
  Reply With Quote
Old 04-20-2019, 07:15 AM   #9
adamjankowski adamjankowski is offline
Active Member
 
adamjankowski's Avatar
 
Oct 2017
25
261
46
Default

Does the 7.1 ch Audio Reformatting need to be set at Auto or Off?
  Reply With Quote
Old 04-20-2019, 07:23 AM   #10
DJR662 DJR662 is offline
Blu-ray Ninja
 
DJR662's Avatar
 
Feb 2009
27
Default

Quote:
Originally Posted by adamjankowski View Post
Does the HDMI(video) Output Mode and HDMI (audio) Output mode need to be set to a particular mode? There are two options for both - Auto and Video + Audio.
You should be good with Video set to Automatic and Audio set to Audio Only.

Quote:
Originally Posted by adamjankowski View Post
Does the 7.1 ch Audio Reformatting need to be set at Auto or Off?
I use Off since I don't have a 7.1 system and even if I did, I would still leave it at off since I would want 5.1 audio to be played as such.
  Reply With Quote
Old 04-20-2019, 07:43 AM   #11
adamjankowski adamjankowski is offline
Active Member
 
adamjankowski's Avatar
 
Oct 2017
25
261
46
Default

It's not working and I have no idea why. There has to be a simple reason, but no idea.
  Reply With Quote
Old 04-20-2019, 08:04 AM   #12
DJR662 DJR662 is offline
Blu-ray Ninja
 
DJR662's Avatar
 
Feb 2009
27
Default

Well, I'm out of ideas. You said it previously worked with the X800 so I guess it's not a setting on your receiver. Perhaps someone else could chime in. It's probably for a simple reason like you said...

Good luck!
  Reply With Quote
Old 04-20-2019, 09:24 AM   #13
CSM101 CSM101 is offline
Senior Member
 
CSM101's Avatar
 
Nov 2012
224
2690
504
14
Default

Did you make sure the receiver was in the correct mode? Which optical input did you connect it at?
  Reply With Quote
Old 04-20-2019, 05:15 PM   #14
adamjankowski adamjankowski is offline
Active Member
 
adamjankowski's Avatar
 
Oct 2017
25
261
46
Default

Quote:
Originally Posted by CSM101 View Post
Did you make sure the receiver was in the correct mode? Which optical input did you connect it at?
As far as I know it is. Same mode I had it in before. I put in the DVD optical input.

Last edited by adamjankowski; 04-20-2019 at 05:28 PM.
  Reply With Quote
Old 04-20-2019, 05:28 PM   #15
RodChester RodChester is offline
Blu-ray Knight
 
RodChester's Avatar
 
Jun 2009
Illinois
63
130
2525
141
73
Default

Did you try another optical cable. They can be somewhat fragile and the one you are using might have broken.
  Reply With Quote
Old 04-20-2019, 05:52 PM   #16
chip75 chip75 is offline
Blu-ray Archduke
 
chip75's Avatar
 
Oct 2010
Wales
16
2170
2072
8
Default

Home > Setup > Player Settings > HDMI > Advanced Settings > Audio Output > On/Off

Select Off.
  Reply With Quote
Old 04-20-2019, 07:59 PM   #17
CSM101 CSM101 is offline
Senior Member
 
CSM101's Avatar
 
Nov 2012
224
2690
504
14
Default

Quote:
Originally Posted by adamjankowski View Post
As far as I know it is. Same mode I had it in before. I put in the DVD optical input.
What mode did you have it in before?
Just to make sure, you have the optical cable hooked up to the optical dvd input on the back of the receiver. Did you make sure that you put your receiver on dvd input mode with your receiverís remote? Iím only stressing this because one time I hooked up all my equipment and couldnít get any sound. After troubleshooting for nearly two hours, I realized I was using the wrong input mode. Sometimes itís the little things.
  Reply With Quote
Old 04-20-2019, 08:04 PM   #18
adamjankowski adamjankowski is offline
Active Member
 
adamjankowski's Avatar
 
Oct 2017
25
261
46
Default

I got it figured out thanks to a member on here.

I had to re-assign the input source - from coaxial to optical. You have to go into a menu on the amplifier and put in the right code. Not as easy to set up as today's systems, for sure. There is a code either to be entered or pressed in a menu.

Thanks for the replies, everyone! Appreciate it! This player made a significant transformation in picture quality on my 4K discs.
  Reply With Quote
Thanks given by:
Robert Zohn (04-20-2019)
Reply
Go Back   Blu-ray Forum > Ultra HD Blu-ray and 4K > Ultra HD Blu-ray and 4K Hardware and Technology


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 06:44 AM.